Hello Guest it is January 19, 2020, 02:50:47 PM

Author Topic: Mach3 did not start router spindle automatic using SSR relay  (Read 409 times)

0 Members and 1 Guest are viewing this topic.

Mach3 did not start router spindle automatic using SSR relay
« on: August 07, 2018, 12:53:15 PM »
I've been trying to get Mach3 to stop/start my router through a BOB connected through pin 17 to a SSR. I have the spindle relays activated and output 1 set to the proper port and pin.  I can get it to toggle on and off with the F5 key and with the spindle button.  When I try to run G Code command M3S20000 or M5 nothing happens. I have also tried to enter M3 and M5 in the diagnostic screen with no results.
Any help will be greatly appreciated. Thanks
Re: Mach3 did not start router spindle automatic using SSR relay
« Reply #1 on: August 07, 2018, 01:05:16 PM »
You likely don’t have the M codes assigned to pin 17. F5 works because it is assigned to the spindle by Mach
Re: Mach3 did not start router spindle automatic using SSR relay
« Reply #2 on: August 07, 2018, 01:19:40 PM »
I am newest for all of this can explain me more. how to assign M codes. also I seen LED on in breakout board when I use M3 and off when M5. F5 key just board LEDs on/off not spindle.
Thanks
« Last Edit: August 07, 2018, 01:28:57 PM by Ubaidali »
What SSR relay used to router on/off using onboard spindle on/off terminal
« Reply #3 on: August 08, 2018, 07:56:35 AM »
I need setup using router on/off on board connection Pin 17 for spindle on/off . I used SSR relay wiring from Pin 17 I can't get router on/off while running gcode. all pins have assign but no results.
while sending M3 and M5 MDI screen Breakoutboard LEDs on/off router can't starting. What I am missing any help will greatly appreciate.

Thanks
« Last Edit: August 08, 2018, 07:58:47 AM by Ubaidali »