Hello Guest it is May 13, 2021, 03:09:31 AM

Author Topic: Toolpath not showing on custom profile  (Read 1167 times)

0 Members and 1 Guest are viewing this topic.

Toolpath not showing on custom profile
« on: August 03, 2018, 04:51:51 PM »
I am building my first cnc plasma cutter and installed Mach4 and the CSMIO/IP plugin, if it matters, and made a custom profile according to its instructions, the settings were mostly for the hardware setup and units. The problem is when I load a G-code on that profile I can't see the toolpath but if I open the default Router profile and load the g-code the toolpath is visible, am I missing something?

Thanks
Oscar
Re: Toolpath not showing on custom profile
« Reply #1 on: August 04, 2018, 01:27:14 AM »
Hi Oscar,
I don't have a CSMIO/IP and unfamiliar with its plugin. There are a few Mach4 users of the CSMIO but understand that the plugin is still in its
infancy and the personell at CSLabs have rather 'gone off the boil' when it comes to support, a shame because they used to have a great reputation
for support.

None-the-less I don't think the issue you have described has anything to do with, or at least not directly, your CSMIO plugin. My understanding is that
the tool path drawing is a feature of Machs core, not any motion plugin.

What version Mach4 are you using? I'm going to assume its the latest build....

With the default router profile open Configure/Control (note this used to be called Mach in earlier builds)/Toolpath. Pay very close attention to the settings made there.
Now open your profile (with the CSMIO) and compare the settings.

I have for instance manipulated those settings on occasion. I found for instance when viewing the toolpath for a printed circuit board etch path that the rapid
moves, typically red in colour confused the look of the tool path. I elected to make them the same colour as the background...a bit crude and not perfect
but it improved the look of the toolpath that I could determine those critical details which had hitherto been obscured.

I'm wondering if somehow the colours have been changed.....can't hurt to look. There was a thread on the forum recently that discussed the line weight that the
toolplath was drawn with. As I recall NFS has made changes that allow some of those settings to be manipulated. I'll try to fid it....it may give you some ideas
you can pursue.

Craig
My wife left with my best friend...
     and I miss him!
Re: Toolpath not showing on custom profile
« Reply #2 on: August 06, 2018, 01:36:21 PM »
Hi,
Those settings were actually the first thing I thought was wrong but nothing changed when tried other colors or line widths.

Oscar
Re: Toolpath not showing on custom profile
« Reply #3 on: August 06, 2018, 02:26:17 PM »
Hello Oscar,

Is your machine homed and zeroed before you load the g code file? Have you tried regenerating the toolpath? Have you tried zooming in or out in the toolpath window? If the g code is loading, a toolpath should be generating. I'm wondering if it is just "out of sight".

-Bryanna
Newfangled Solutions Helpdesk: http://support.machsupport.com
YouTube Support Channel: https://www.youtube.com/c/MachSupportOfficial
Re: Toolpath not showing on custom profile
« Reply #4 on: August 07, 2018, 11:37:09 AM »
Hi,
Byranna has reminded me that I've had exactly the issue that you describe and for exactly that reason. That is that the toolpath of the object/part
is so small because of the scale of the display.

If you zoom in you may fid the toopath is actually there, its what happened in my case. What I found  was that if my machine is not referenced (homed)
prior to loading a Gcode file and associated toolpath that is possible for the machine to set a scale such that the toolpath disappears because its so small.
The second thing that I do is have the tooplath display the table limits. Its convenient to confirm that the tooplath is within the machine boundaries
but it also constrains Mach to selecting an appropriate scale with which to draw the toolpath.

Configure/Control (also called Mach on earlier builds)/Toolpath  check <display toolpath limits>

Craig
My wife left with my best friend...
     and I miss him!
Re: Toolpath not showing on custom profile
« Reply #5 on: August 09, 2018, 03:34:08 AM »
The machine is still in the making so I am not connected to it. I turned the Tool Path Limits ON and I can see the yellow line of the work area, I also made the Line width to 150 and still can't see the paths. Also is there a way to change to mouse behaviour, trying to pan with 2 mouse buttons has probably being the most frustrating thing I have done in my life.

Oscar
Re: Toolpath not showing on custom profile
« Reply #6 on: August 09, 2018, 03:43:42 AM »
Hi Oscar,
yes I've had the same battle with the mouse buttons. I've not found anyway to get a round it yet.
One feature that I do use is <Jog Follow> mode. Try it out.

Have you tried referencing your system before loading the code?

If I understand the explanation given elsewhere Mach will attempt to draw the tooplath at such scale so as to also include the 0,0,0 origin.
Thus if your machine is not referenced it could be that the 0,0,0 is at some considerable distance from the toolpath and therefore Mach has to draw a such a
large scale that your toolpath disappears.

Craig
My wife left with my best friend...
     and I miss him!
Re: Toolpath not showing on custom profile
« Reply #7 on: August 09, 2018, 04:25:08 AM »
Hi Oscar,
yes I've had the same battle with the mouse buttons. I've not found anyway to get a round it yet.
One feature that I do use is <Jog Follow> mode. Try it out.

Have you tried referencing your system before loading the code?

If I understand the explanation given elsewhere Mach will attempt to draw the tooplath at such scale so as to also include the 0,0,0 origin.
Thus if your machine is not referenced it could be that the 0,0,0 is at some considerable distance from the toolpath and therefore Mach has to draw a such a
large scale that your toolpath disappears. I also attached the gcode file, its very simple.

Craig

Well the Reference All button is greyed out, I believe because I am not connected to the machine.

But I found the problem, the moment I disable the Z axis from Axis Mapping and restart Mach4, the toolpath is not visible anymore, so the question now is if this is normal behaviour by Mach4 and I just need to check the settings on CamBam, I had used a Profile operation for the cad drawing I loaded in CamBam which is a 2D machining operation.
« Last Edit: August 09, 2018, 04:27:01 AM by ckambiselis »