Hello Guest it is July 10, 2020, 12:08:38 AM

Author Topic: Mach3 pin 15 Always active  (Read 593 times)

0 Members and 1 Guest are viewing this topic.

Mach3 pin 15 Always active
« on: July 31, 2018, 03:45:30 AM »
I tried a few searches so as to not double up posts but didn't find a post that helped.

Recently bought a X2 converted to CNC from a guy that has used it for years. I need a probe in my machine, and this is where my trouble starts. Pin 15 is always showing as triggered. I changed cables, break out boards, switches, all of it but PC components.

Anyone have an idea what might be the cause? Do I need to get a whole new PC?

Offline Tweakie.CNC

*
  • *
  •  8,352 8,352
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach3 pin 15 Always active
« Reply #1 on: July 31, 2018, 04:24:52 AM »
I presume you have Port#1 Pin 15 set as the Probe Input in Ports & Pins. Have you tried changing the Active Low state ?

KEEP SAFE !
Re: Mach3 pin 15 Always active
« Reply #2 on: August 01, 2018, 01:03:42 AM »
Yea, I changed all of the setting to see what would happen, it would either move to always triggered or never triggered. I changed it from the probe to a limit switch that was working fine. Same results. I changed the break out board, same results. Really at a loss. I can work around it by doubling up a limit switch, just not ideal.

Offline Tweakie.CNC

*
  • *
  •  8,352 8,352
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach3 pin 15 Always active
« Reply #3 on: August 01, 2018, 01:27:33 AM »
If you have done all the tests then it sounds like Pin 15 from the Parallel Port is dead.
Either another PC or perhaps fit a new PCI Parallel Port card (5 Volt version - this thread refers; http://www.machsupport.com/forum/index.php/topic,34848.msg239910.html#msg239910 )
KEEP SAFE !