Hello Guest it is May 13, 2021, 11:42:34 PM

Author Topic: configure menu greyed out!  (Read 1205 times)

0 Members and 1 Guest are viewing this topic.

configure menu greyed out!
« on: July 28, 2018, 01:13:37 PM »
I turned on the computer this morning and the configure menu and the edit screen options in Mach4 are greyed out.  Normally as long as Mach4 is not enabled, I am able to access these. Everything else seems to work fine, but I can't make any changes to anything. It is as if Mach4 thinks that it is enabled when it is not.  I have tried opening it without anything plugged into the computer (ess) and I get the same results.
Anybody have any ideas??!!
Thanks
Re: configure menu greyed out!
« Reply #1 on: July 28, 2018, 05:16:38 PM »
Hi,
can you open Mach4 and look to the lower right to determine the screenset in use? Does this compare to your expectation?

I've had on a couple of occasions when fooling around with Mach broken the editable GUI and then Mach would open a non editable screen
as a sort of primitive backup to the real thing.

The application that uses an editable screenset is Mach4GUI.exe whereas the basic screenset (non editable) is wxMach.exe.

Craig
My wife left with my best friend...
     and I miss him!
Re: configure menu greyed out!
« Reply #2 on: July 30, 2018, 12:03:17 PM »
Hey, thanks for the reply. 
Yes, the screensets are in good order. The real problem is that the menu bar is behaving as if Mach4 is enabled when it is not. It seems that the inability to edit the screen is just a result of that problem.
Re: configure menu greyed out!
« Reply #3 on: July 30, 2018, 02:20:39 PM »
Hi,
that pic shows Mach is enabled (button green vs red flashing when disabled).
Can you manually cause a limit switch to operate to cause an Estop?

Craig
My wife left with my best friend...
     and I miss him!
Re: configure menu greyed out!
« Reply #4 on: July 30, 2018, 03:44:29 PM »
Hello,

I sent out a response to your ticket, but I wanted to share the solution here in case others have this same issue. When OP lost power, Mach4 had to close unexpectedly. This can cause some funky things to happen to your profile. What happened here is that the Operation Lock setting was turned on in his Machine.ini file. The fix was to open up the Machine.ini file and change OpLock=1 (on) to OpLock=0 (off).

-Bryanna
Newfangled Solutions Helpdesk: http://support.machsupport.com
YouTube Support Channel: https://www.youtube.com/c/MachSupportOfficial
Re: configure menu greyed out!
« Reply #5 on: July 30, 2018, 04:02:49 PM »
Yes!! It worked! Thanks Brianna, and thanks Craig for the suggestions!!

-David