Hello Guest it is April 20, 2024, 03:13:37 PM

Author Topic: E stop and limit issues and not on new setup  (Read 1032 times)

0 Members and 1 Guest are viewing this topic.

Offline Aegir

  •  30 30
    • View Profile
E stop and limit issues and not on new setup
« on: July 23, 2018, 05:07:39 AM »
OK, so this is not a new topic I know, but my situation is a little different I think.
My own assumption at this point, is my switch is no longer usable.

So my machine is not a home build or new, it has done over 2200 spindle hours, so this is not me struggling to get settings correct. I stay away from any settings and never play with it.
Everything has been going fine until yesterday, when I came out to the garage to see the machine had stopped near the end of the job. Rather than change the code to suit the milled material already, I just re-ran the program and walked off.
I came out later to find it had stopped again at what appeared to be the same spot. I changed the tool paths to suit material removed and I altered the path itself so the offending line of code was gone and worked OK.
( This was cutting soft jaws by the way)   So next to that I ran another cut into those soft jaws which milled ok.

This morning I put some stock into that original cut, found G54 and hit start. About 40 mins into the job it stopped and had the ''external e stop requested '' flashing. Not sure what it had the night before, as I didn't take note.
I re-ran the program and same result. I did it again and it seemed to work and when it went to cut I saw straight away it was coming down offline. Turns out the Y axis had moved approx 4mm or so.
Found G54 again, but this time while rechecking the X axis , ''e stop requested '' several times.
I went through this all again, same results and Y axis off again.
Then I get a message saying something like ''requested home switch is active please fix then home'' .   In the diagnostic page Y axis is lit up, then starts flashing

Fast forward half a day, I cleaned the whole machine, all the switches and still have the issues.
I tried changing the pin on the Y axis , which removes the light , but does not see the switch, which is about what I expected. The switch has a little ball on top which is not stuck and moves in and out freely when pushed.
Nothing is obstructing the switch and the cover is now removed .
If I get the Y axis away from the switch then put it back on pin 11 again and push home, then it moves 10mm or so and triggers and then stays active.
Attached is the XML file .

X homes ok and since the issue finding G54 when it triggered, it has been fine.
Z homes fine.
X and Z can be jogged anywhere without issue as well.

Y now triggers every single time I try.

SO, any ideas?