Hello Guest it is July 08, 2020, 01:46:03 AM

Author Topic: angle slot wizard being strange on arc slot.  (Read 606 times)

0 Members and 1 Guest are viewing this topic.

angle slot wizard being strange on arc slot.
« on: July 20, 2018, 11:57:27 PM »
ok, first up...sorry if this isnt the place. i tried searching and came up trumps.

so. im trying to cut a slot and an arc slot.

using the included angle slot wizard, i can make the straight slot no problems.

now, i then want an arc using the same xy zero point as the straight slot.

so... i plug in the xy coords, the radius of arc, blah blah. all good.

when i tap in the start and finish angles though...

first off... i type in 270 say. it decides it requires a minus sign in front of it. thats no problem. any figure over 90 and it automatically sticks a minus sign in front of it. i can work around that and figure out my coords to be in reverse...

the problem is that if i try any arc with a start and finish angle of anything other than 90 to 270, it wont generate the code. i cant get rid of the minus sign. it tells me things like arc chord length is a negative value, once it threw back an error that the tool diameter was too small...

it used to work, ive used it before (like, before i formatted my HD and reinstalled win7 and downloaded the latest mach3 release.... if that means anything?), but right now...its not doing what is expected!

maybe some screenshots will explain it better.
screenshot 1. the only arc it has decided its willing to create.

screenshot two. lets try changing that start angle...all is good, it did that. it even allowed 110 degrees to stay as a positive.

screenshot 3... my desired start and finish angles. i did NOT put that minus sign in front of 135!

and obviously, its the same g-code as screenshot2. it simply wont generate my desired arc.

i have just spent an hour or so plugging in various coords and so far, thats all it is doing. creating an arc from around 90 degrees start to 270 degrees finish, a 180 degree arc facing the wrong way... i actually want from 45 to 135.

so...is there something wrong with what i am doing here, or do i give up and go use the arc cut wizard instead? i just prefer the finish and ramp on the angle slot wizard... for obvious reasons.
« Last Edit: July 21, 2018, 12:16:24 AM by HeadSmess »
Re: angle slot wizard being strange on arc slot.
« Reply #1 on: July 21, 2018, 12:11:54 AM »
just for giggles. heres a screenshot if i try starting at 135 and finishing at 45...


once again. 135 has automatically become negative.

its not creating the gcode but just keeps the last toolpath that did generate. (screenshot2)

note that my chord length/radius lengths are now negatives.

last time i did this it threw back the tool diameter error...

it basically appears that it wont tolerate any start angle under 90. i need it to start at 45! grrr!

i suppose i could live with it, and cut that straight slot at 45, but its a nuisance cus then i have to do some maths...

and last, heres a screenshot of my combined final g-code...with the wrong arc!


why? why does it doooo this to me?

lol...

i think im going to go set up the rotary table and just cut this manually now... not in the mood for technology playing silly buggers!

« Last Edit: July 21, 2018, 12:18:50 AM by HeadSmess »
Re: angle slot wizard being strange on arc slot.
« Reply #2 on: July 21, 2018, 12:32:00 AM »
last one...i just tried my desired start and end points, 45 to 135.

but i tried changing the centre points to 0.

and now it works.

if i try any centre point other than 0,0....it wont generate.

oh well... guess i just move to 20,10 and re-zero there...

cuss cuss cuss...