Hello Guest it is July 08, 2020, 01:44:54 AM

Author Topic: Didn't read a warning message and now I can't jog  (Read 604 times)

0 Members and 1 Guest are viewing this topic.

Didn't read a warning message and now I can't jog
« on: June 27, 2018, 12:54:57 PM »
I'm new here so forgive me. I couldn't find anything searching

My setup:
I have 2 cncs running off one ESS, a mill and router. The router is on port 1 and the mill is on Port 2

(I'll have to get you the exact versions and stuff later, I thought I had them on my work computer but I don't)
Computer - Win8, either 4 or 6 GB of Ram, i5 processor Surface Pro1
Mach3 - the version suggested by Warp9
ESS - ~Approximately the Lastest as of Aug ~ 2016
Port 1:
TB6560

Port 2:
k4030L drivers into a C10 board into ESS

Problem: I can run gcode just fine, I just can't jog. I click the jog button, it lights for a fraction of a second then goes away. I hit Tab to get the MPG. I can hit shuttle, that blinks on/off in yellow. I cannot toggle jog, jog/cycle/step, I cannot jog with the triangles

What I think the message said:

Something something something "Ess Smooth stepper made a change, if you did not mean to make this change please contact support" Something something something.

I have no idea what that message said or meant or anything and everything went to s*** after it popped up

Here's what I was doing:
I was attempting to get a touch probe to work, the type where you ground one end to the endmill and the other to a plate. The mill then moves to touch the plate, then zero's the dro etc..

My 'problem' was that the TB6560 doesn't have a port for a probe. I figured, no worries, I'll just use the one off the other. So first I was checking to see if one of the extra ports on the TB6560 could sub as a pin for a probe, I started checking limit switch pins on Port1 going from 1,2,3 to 23,24,25 (IOW I set xhome, yhome, zhome and probe to pins 1,2,3,4 respectively. I then touched the ground clip to the plate and checked the 'LEDs' on the diagnostics page for action. Nothing lite up so I incremented them to 5,6,7,8 and so on to 25.)

After that, I had this "brilliant" thought to just use the probe pin on the C10 board, pin 12 or 13 (I forget which I had setup at the moment but we'll just assume it's 12 for this). So I went back into the Ports & Pins screen and changed the probe from Pin 25 Port 2, to Port 1 Pin 12.

When I closed the Ports & Pins screen, I got the pop up. usually that pop up is the ESS lost connection or something. This time it was something different but muscle memory took over and I closed it before reading it. I then attempted to jog the machine over to the plate and do the probe. I couldn't jog it. "Hmm... weird", I then noticed the Jog button on screen 1 was no longer lit. I clicked it on, and it went green then black again. Then I tried every other screen to see if I could jog it and nothing worked and that's when I might have cried or got something in my eye, I'm not sure...

Here's what I tried to fix it.

1) Tried every possible method to toggle jog on, MPG, TAB, Ctrl+ arrows, Shift + Arrows etc.
2) Turn everything off and on again.
3) Verified I could run GCode, I can so it's not a motor coms issue
4) Went back to settings I had backed up when the machine was first installed - Nothing...
5) I thought it was because ESS was seeing 6 Drivers, so I figured, eh, maybe it won't allow jogging because it doesn't know what I want to jog. So I uplugged port 1. No change..

((Frustration set in))

6) Uninstalled Mach and reinstalled it - Jog still doesn't work

To Do:

Tonight I am going to remove everything Mach and ESS related and start from 0, if that doesn't work... well lets not think about that just yet.




Re: Didn't read a warning message and now I can't jog
« Reply #1 on: June 27, 2018, 02:38:54 PM »
Ok, after going back and forth with Andy over at SmoothSteppers, I'm pretty confident that the missed message had nothing to do with my current predicament.

Some things I have to check on :

Soft Limits, did I turn them on accidentally?
Limit OverRides - Can they be toggled?

Offline Tweakie.CNC

*
  • *
  •  8,350 8,350
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Didn't read a warning message and now I can't jog
« Reply #2 on: June 28, 2018, 06:39:42 AM »
Just a thought…

Because of the way in which the Smooth Stepper stores it’s data, when setting things up or making changes in the Mach or ESS configuration, it is possible (quite easy in fact) to create a corrupt .xml file.

My suggestion…

When you re-install Mach create the profile from scratch also (don’t just copy across the original .xml file).

Tweakie.
KEEP SAFE !