Hello Guest it is June 16, 2019, 11:31:51 PM

Author Topic: Calibrating for A axis  (Read 630 times)

0 Members and 1 Guest are viewing this topic.

Calibrating for A axis
« on: June 22, 2018, 10:30:20 PM »
A while ago, I posted about my experience buying a machine from Pacific Tooling/Roger Webb. In that post, I mentioned that Roger had provided a pirated copy of Mach3 and a couple of people responded by saying that the pirated copies were often very 'buggy'. This has left me a bit paranoid because, as a relatively new user, I'm never quite sure now whether a problem is from my ignorance (the most likely explanation LOL) or from bugs in my copy of Mach3. I should mention here that I do have a licensed copy but Roger insisted that I use his copy as it had been set up specifically for my machine.

All that being said, I have an issue that I can't solve. When I bought this machine, I also bought with it the 4th axis option. To date I have been spending my time familiarising myself with the std router functions but now I am ready to try the 4th axis. I started by watching the Vectric Aspire tutorial on setting up a wrapped job and making a simple cylinder from a square length of timber.

The first thing I discovered was that the calibrations (steps per unit) had changed when I used the 4th axis. (Should this happen?) Having recalibrated the Y & Z axis and the A axis, I start my job ( a simple rounding job), I find that, while the material is 450mm long, the Y axis only travels about 40mm.

Am I missing something? Or might it be a bug?
Re: Calibrating for A axis
« Reply #1 on: June 23, 2018, 01:39:16 AM »
Hi,
glad you got the licence drama sorted, it sort of makes you feel like a mug... and that's on top of being just plain confused about Mach!

So you have had reasonable success with making things with the machine as three axis? If that's the case then you must have the steps per unit values in the respective axis
tuning pages correct or all your parts would turn out misshapen or the wrong size.

Now that you have started to use the 4th axis things are going crazy? May I suggest open the motor tuning pages and have a look at the steps per unit value in each of your
three linear axes. Have they changed? They should not have, if they have then the xml file is corrupt and you will have to try one of your backups, you do have one I hope, or
redo your profile.

My guess is that the steps per unit values have NOT changed. What has happened is that you have enabled another axis an put an appropriate number in its steps per unit value.
What is the steps per unit value for your new A axis? If I made a guess and said 55 steps per unit, we can carry on.

Remember that that value is the number of steps Mach issues to get the A axis to move 1 degree, so it would have to issue 55 x 360 = 19800 steps per revolution.

Lets say you want the X axis to move 450mm and the A axis to rotate once and you issued a move like:

G1 X450 A360 F360
The A axis would take 1 minute to rotate 360 degrees and so the X axis will slow down so it arrives at its endpoint at the same time, ie 450mm per min. You can see that adding an A axis
may well have a significant effect on the speed of your remaining axes.

Have a look at the steps per unit values of all your axes a post them.
Confirm that they are good by issuing and MDI for each axis in turn and confirm that its moving the right distance:
G0 X100....did the X axis move 100 mm?
G0 Y100....did the Y axis move 100mm?
G0 Z100....did the Z axis move 100mm
G0 A90....did the A axis move 90 degrees?

Craig
My wife left with my best friend...
     and I miss him!
Re: Calibrating for A axis
« Reply #2 on: June 23, 2018, 02:02:08 AM »
Thanks Craig. I'm not in my shed atm so I'll follow your leads over the next day or two. However, to answer a couple of your questions, yes I have had no problems with 3 axis jobs and the steps per unit were fine. As you suggest, the problem started as soon as I introduced the 4th axis.

I'll try and work this out from your notes but I may need to seek explanation of some of your terms, if that's ok. Wish me luck :-)
 Best regards
Doug
Re: Calibrating for A axis
« Reply #3 on: July 07, 2018, 01:51:01 AM »
Hi,
glad you got the licence drama sorted, it sort of makes you feel like a mug... and that's on top of being just plain confused about Mach!

So you have had reasonable success with making things with the machine as three axis? If that's the case then you must have the steps per unit values in the respective axis
tuning pages correct or all your parts would turn out misshapen or the wrong size.

Now that you have started to use the 4th axis things are going crazy? May I suggest open the motor tuning pages and have a look at the steps per unit value in each of your
three linear axes. Have they changed? They should not have, if they have then the xml file is corrupt and you will have to try one of your backups, you do have one I hope, or
redo your profile.

My guess is that the steps per unit values have NOT changed. What has happened is that you have enabled another axis an put an appropriate number in its steps per unit value.
What is the steps per unit value for your new A axis? If I made a guess and said 55 steps per unit, we can carry on.

Remember that that value is the number of steps Mach issues to get the A axis to move 1 degree, so it would have to issue 55 x 360 = 19800 steps per revolution.

Lets say you want the X axis to move 450mm and the A axis to rotate once and you issued a move like:

G1 X450 A360 F360
The A axis would take 1 minute to rotate 360 degrees and so the X axis will slow down so it arrives at its endpoint at the same time, ie 450mm per min. You can see that adding an A axis
may well have a significant effect on the speed of your remaining axes.

Have a look at the steps per unit values of all your axes a post them.
Confirm that they are good by issuing and MDI for each axis in turn and confirm that its moving the right distance:
G0 X100....did the X axis move 100 mm?
G0 Y100....did the Y axis move 100mm?
G0 Z100....did the Z axis move 100mm
G0 A90....did the A axis move 90 degrees?

Craig

Hi Craig,

Problem sorted. Thanks for your help. Although Roger Webb had insisted that I use the pirated copy of Mach3 that his factory had 'set up' for my machine, I gave up on that copy and set up my licensed copy properly for this new machine. Magic and sorcery.....it worked!

Thanks again
Best regards
Doug
Re: Calibrating for A axis
« Reply #4 on: July 07, 2018, 01:57:14 AM »
Hi,
kool, glad you got it sorted.

I sometimes wonder if we would be better off if Mach used 'revolution' as a rotational unit, so 90 degrees would 0.25 and 360 degrees
would b 1.0 etc.

Craig
My wife left with my best friend...
     and I miss him!
Re: Calibrating for A axis
« Reply #5 on: July 07, 2018, 02:02:24 AM »
Hi,
just had an even better idea.....Mach should use radians as unit of angular measure thus 90 degrees would be 1.570796,
180 degrees would be 3.14159265 and 360 degrees would be 6.2831853.

Yeah! That would be great......and so simple!!!! Everyone would luv it!!!  LOL

Craig
My wife left with my best friend...
     and I miss him!
Re: Calibrating for A axis
« Reply #6 on: July 07, 2018, 06:21:14 PM »
LOL!