Hello Guest it is July 11, 2020, 05:04:46 PM

Author Topic: Feed rate speed error  (Read 1275 times)

0 Members and 1 Guest are viewing this topic.

Feed rate speed error
« on: June 12, 2018, 12:39:40 PM »
I've run into an issue with a laser welding station that I've designed with Mach3 and SS board and can't seem to find the cause of a feed rate error.

I've found that I need to use a g-code feed rate 4x what the actual feed rate is.  For example, If I want  600mm/min I have to enter F2400 instead of F600. 

Attached is my XML if anyone is able to help resolve the issue it would be great.

Thanks,
Brian

Offline ger21

*
  • *
  •  6,282 6,282
    • View Profile
    • The CNC Woodworker
Re: Feed rate speed error
« Reply #1 on: June 12, 2018, 02:24:27 PM »
Is the FRo set to 25%?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Feed rate speed error
« Reply #2 on: June 12, 2018, 02:45:29 PM »
Nope - its set to 100%
Re: Feed rate speed error
« Reply #3 on: June 12, 2018, 03:04:08 PM »
Hi,
can you confirm the accuracy of your steps per unit values by issuing this MDI:

G0 X0
X300

Does the X axis move 300mm?

Craig
My wife left with my best friend...
     and I miss him!
Re: Feed rate speed error
« Reply #4 on: June 12, 2018, 03:28:25 PM »
My system only has 100mm stages so I entered X50 and it moved the corresponding 50mm.  So correct distance is traveled.
Re: Feed rate speed error
« Reply #5 on: June 13, 2018, 03:08:33 AM »
Hi,
well that narrows things down and starts to look like a more mysterious problem.

Clearly you have the steps per unit right for otherwise your X50 move would not have moved 50mm.

Could it be that your controller can't produce pulses fast enough to go at your maximum desired speed?

Are you using a parallel port and if so what kernel frequency have you set? What are your Step per Unit values?
With those numbers we can work out what the potential best speed the controller can drive your machine, maybe its out of whack somehow.

Craig
My wife left with my best friend...
     and I miss him!
Re: Feed rate speed error
« Reply #6 on: June 13, 2018, 11:40:47 AM »
Craig,

I've got a smooth stepper control board.  I've got the kernal speed set to 100khz but have tried 25khz with no change.  The steps per unit (mm) is set to 200 as I'm using a teknic clearpath motor that is setup for 1000 pulses per rev and the linear leadscrew pitch is 5mm/rev.

Brian
Re: Feed rate speed error
« Reply #7 on: June 13, 2018, 04:42:26 PM »
Hi,
the smoothstepper should be any amount fast enough. Despite having a kernel speed of only 25kHz
even that would put the max speed at:

(25,000 / 200) * 60 =7500 mm/min,  ie plenty fast.

Is it possible that you have some setting within the Clearpath which limits the speed? What model?

Craig
My wife left with my best friend...
     and I miss him!
Re: Feed rate speed error
« Reply #8 on: June 15, 2018, 02:16:17 PM »
craig,

delayed response... but I looked at the teknic settings and don't see anything that would be impacting the speed.  I'm using the step and direction clearpath motor.  Just for the hell of it, I doubled the input resolution and doubled the Mach3 motor tuning (steps per).  As expected this didn't impact my feed rate (still 4x slower than should be) and I'm still traveling the correct distances. 

I'm sure there is a setting somewhere that I have set incorrectly but I just don't know what it could be...
Re: Feed rate speed error
« Reply #9 on: June 15, 2018, 02:38:10 PM »
ok so I figured something out.  All this time I've been doing multi-axis moves.  When I did a single axis the feed rate is correct.  When I take out the rotary 4th axis and do an XYZ move then I have speeds that are 1/3 slower that expected not 4x.  So I'm not a g-code expert but is the F value per axis or is it the RMS value for all the axis? 

I've got my rotary set for 53.333 steps/degree and so I think that might be the cause for the significant slowing of the other axis???