Hello Guest it is April 11, 2021, 08:06:05 AM

Author Topic: Mach4 V3804 Lua not working with Lua instructions on Screen  (Read 1087 times)

0 Members and 1 Guest are viewing this topic.

Offline Mauri

*
  •  320 320
    • View Profile
Hi,
I have a perfectly working Mach4 V3481 with lua Screen instructions to operate all the buttons on the Controller including the Spindle.
They fully interact with Mach4 V3481.

I have tested two screens one New based on the one that came with V3804 and my Old one Based on V3481.
Both do not operate or interact with my button controls on the controller or spindle.

However both these screen work fine with Mach4 V3481.

So the control of buttons has changed in the new Mach4 V3804.
Does anyone know how to fix this.

Regards,
Mauri.
Re: Mach4 V3804 Lua not working with Lua instructions on Screen
« Reply #1 on: June 08, 2018, 07:42:19 PM »
Hi Mauri,
the screenset that you had working with V3481....did it have any modifications and tweaks that you applied?

Craig
My wife left with my best friend...
     and I miss him!

Offline Mauri

*
  •  320 320
    • View Profile
Re: Mach4 V3804 Lua not working with Lua instructions on Screen
« Reply #2 on: June 08, 2018, 07:48:12 PM »
Craig,
Yes both My New Screen set based on Mach4 V3804 and My Screen set based on Mach4 V3481 have my Lua Code in them.
As I have stated both work will all controls with V3481 but not with V3804.
Regards,
Mauri.
Re: Mach4 V3804 Lua not working with Lua instructions on Screen
« Reply #3 on: June 08, 2018, 08:06:08 PM »
Hi Mauri,
when you modified the original standard screenset did you rename it?

The reason I ask is that when you download and install a new Mach build you get new standard screensets as well and they overwrite the standard screensets you aready have.
Is it possible that the fresh download has overwritten your screenset?

I have had that happen before, its not enough just to have a uniquely named profile, you should make a copy of one of the standard screen sets and uniquely name that
as well. Any tweaks or modifications you apply to it will then be preserved when you download a new build.

I downloaded V3804 about three weeks ago and it works perfectly with my old screenset so I'm thinking the change you have experienced is not due to V3804.

Craig
My wife left with my best friend...
     and I miss him!

Offline Mauri

*
  •  320 320
    • View Profile
Re: Mach4 V3804 Lua not working with Lua instructions on Screen
« Reply #4 on: June 08, 2018, 08:15:45 PM »
Craig,
I always us my naming convention, so that is not the issue.
V3804 just will not read my button controls which includes the spindle on my Controller, nor if you select the on screen buttons do they activate the Controller buttons or spindle button.
So the issue is V3804 reads the Lua code differently to V3481.
I am not sure if you control your Mill via the Controller buttons.
So unless you control you Mill via the controller buttons then you would not see my problem.
Regards,
Mauri.

Offline Mauri

*
  •  320 320
    • View Profile
Re: Mach4 V3804 Lua not working with Lua instructions on Screen
« Reply #5 on: June 09, 2018, 06:50:40 PM »
Hi,
Found the problem it was machine.ini that I used in V3804.
I replaced the profile with the working one from V3481 and now it all works.
Regards,
Mauri.

Offline Mauri

*
  •  320 320
    • View Profile
Re: Mach4 V3804 Lua not working with Lua instructions on Screen
« Reply #6 on: June 10, 2018, 04:07:15 PM »
Hi,
So the issue with V3804 is that I does not update machine.ini.
I compared to two Machine.ini files on V3481 and V3804.
V3481 had all the Mapping for the Button controls which are in the Screen Script.
example
[Signal11]
ID=11
Type=Input
Desc=Input #10
Enabled=1
Negated=1
Mapping=HiCON/[P14] Input 10

But V3804 on had all Mapping=None.
[Signal11]
ID=11
Type=Input
Desc=Input #10
Enabled=1
Negated=1
Mapping=None

Not sure why V3804 machine.ini did not have these Mapping=None for the inputs and outputs and Not being Mapped to HiCON like version V3481.

It is not something the user codes into machine.ini but what Mach4 should have done using the Screen Script like it does with V3481?

Has anyone experienced this problem?

Best Regards,
Mauri.
Re: Mach4 V3804 Lua not working with Lua instructions on Screen
« Reply #7 on: June 11, 2018, 12:47:19 AM »
Hi,
the .ini file is part of your profile, you should be using the profile from the previous build (3481)
with the current build (3804).

You have effectively started with a blank profile and that should not happen when you update.

Craig
My wife left with my best friend...
     and I miss him!

Offline Mauri

*
  •  320 320
    • View Profile
Re: Mach4 V3804 Lua not working with Lua instructions on Screen
« Reply #8 on: June 11, 2018, 04:00:43 PM »
Craig,
I had started to fully update the ini file, but I remember I had to go shopping and forgot about the input and output not being completed.
Later that day when I started the Mill to do a job the MPG was working and I positioned the cutter ready to go, so I presumed that I had completed the task, but I had not.
Regards,
Mauri.
Re: Mach4 V3804 Lua not working with Lua instructions on Screen
« Reply #9 on: June 11, 2018, 06:42:26 PM »
Hi,
crikey!....its a shame when real-life intrudes on your CNC...LOL

Craig
My wife left with my best friend...
     and I miss him!