Hello Guest it is May 15, 2021, 12:48:06 AM

Author Topic: MACH 4 M6 NOT WORKING, i have tried 5 scripts an 2 weeks fighting this  (Read 2374 times)

0 Members and 1 Guest are viewing this topic.


MACH 4 M6 NOT WORKING, i have tried 5 scripts an 2 weeks fighting this 
G0704 3 AXIS MILL, MACH 4, ESS SMOOTH STEPPER FROM WARP9, WIN 10,fusion 360 mach 4 post processor, an now im re installing mach 4 now as i type....

i need manual tool change....not hard wtf,.....they shouldnt sell something that doesnt work an you have to become a computer programmer to make work aaahhhhhhhhhhhhh

i have tried multiple scripts/macros with no luck, i even loaded nazthegaz macro up but its for a table SO I DONT EVEN KNOW IF IT CAN BE MADE TO WORK ON A 3 AXIS MILL, STILL I TRIED IT AN I KEEP HAVING ISSUES WHEN I TRY AN MAKE A MANUAL TOOL CHANGE,...
I start with tool 1 my edge finder loaded up with tool height offsets on an then i hit go to work zero,....i then run my gcode from here,...it gos home tells me what tool to enter an all is good,...then it starts the gcode with tool #12 with offset of 12 but it will change the offset part way through the gcode, then when i get to opt 2 Z gos home then right back down an tool an offset is wrong ,,it usually has the tool 3 that is suppose to be loaded in the offset but the tool 3 will be wrong, sometimes its the tool #from last opt an tool offset of the tool that was suppose to be l;loaded [/b]
Hi,
M6s cause a lot of grief.

Is it possible while you are getting it sorted that you break your code into several distinct Gcode
files, one file one tool?. Saves headaches like those you describe.

Craig
« Last Edit: June 04, 2018, 07:01:57 PM by joeaverage »
My wife left with my best friend...
     and I miss him!
Hi,
aside from anything else if you are manually changing tools you are likely to have to touch off on each
occasion so tool height offsets don't make any sense.

They do make sense and are virtually mandatory with ATCs only.

Craig
My wife left with my best friend...
     and I miss him!
only thing i know to try is to run without tool changes, this is really aggravating that neither newfangled solutions or warp 9 have a machro for this, this isnt hard for them ,, i mean my god thats what they do an they put out something that doesnt work,they were the ones that  talked me into upgrading to mach 4 an to lose the uc100 an  get the warp9 board an it would solve all my problems i was having before....all i did was trade problems an spend another $500.00+ thanks by the way newfangled solutions an warp9.....
i have all my offsets loaded into mach 4 tool library, thats the whole point is so you can run a single g code an not have to keep finding edge of the work piece, we have a tormach 1100 an it use to run on mach 4 an i know other people running mach 3 an they dont have to do that
im a bought to buy the acorn board an try it, its software an board are by the same people, enough with this make it work from different manufactures thats what tormach did,.. they took linux cnc an made it  there own for there machines only , i wish i could get it on mine, you dont have to deal with all this b.s,....... pathpilot is so much better than this headache, every time we run gcode from fusion it runs flawlessly, but i have been working every afternoon for 4 hrs a  day over 2 weeks to reinstall an convert to mach 4, i though i was making progress but every time i fix one problem , another takes its place
« Last Edit: June 04, 2018, 07:11:35 PM by jbraddock »
only thing i know to try is to run without tool changes, this is really aggravating that neither newfangled solutions or warp 9 have a machro for this, this isnt hard for them ,, i mean my god thats what they do an they put out something that doesnt work,they were the ones that  talked me into upgrading to mach 4 an to lose the uc100 an  get the warp9 board an it would solve all my problems i was having before....all i did was trade problems an spend another $500.00+ thanks by the way newfangled solutions an warp9.....


im using tts tormach tools so i dont have to
Hi,

Quote
his is really aggravating that neither newfangled solutions or warp 9 have a machro for this, this isnt hard for them ,, i mean my god thats what they do an they put out something that doesnt work,
Bull*********....M6s are specific to every machine. They have three or four scripts in the examples folder which give a BASIS
on which to make your own, but because every machine is unique you do have to do it yourself.
Mach4 is good at that sort of thing.

If you are prepared to learn those things necessary to customize Machs behaviour  you will find that Mach4 far FAR exceeds Mach3
and to my knowledge other software solutions as well. If you are not prepared to learn then Mach4 is probably not the right
solution for you.

Craig
My wife left with my best friend...
     and I miss him!
Hi,
instead of venting try posting your M6 code and that section of your Gcode file that misapplies the
length offset.

Craig
My wife left with my best friend...
     and I miss him!
ive been trying to learn but its hard to learn when you cant find anything on it,..ive went through all the posts an i haven't found anything on how to fix it yet or anyone who can tell me how to fix it, so at this point its a $500 boat anchor,...i had mach 3 an tool changes worked onit, i dont understand what went wrong between the upgrade,...but thats why i purchased it was because i believed in mach 3 but i dont have time to program every button on it, i want something that i can run gcode,.. not work on a button or a function,...i got other projects to work on an im spending my time working on a program that should a came with proper macros from factory,...or warp9 should give us access to them,  i cant find anything on there website either,...i dont have a problem learning thats what i spent past 2 weeks doing but thats just it im not learning squat,.. at the moment,... if it worked id be happy, but so far i have done nothing but work on making it work an still haven't got it to work right i haven't cut the first part on it yet , i think if i ever do get it to work im gonna cut a ford logo an hanging it on it,