Author Topic: PoKeys 57CNC, and P'25-32 and Mach 3 slave mode not working.  (Read 1261 times)

0 Members and 1 Guest are viewing this topic.

Offline philaro

  • Active Member
  • Posts: 8
    • View Profile
I have PosStep25-32 drivers + Nema 23 motors on the X axis and A axes. I selected A as the slave axis for X. The X axis moves correctly, but the slave motor won't budge. I've tried to isolate the problem with different motors or axis and even cables. The LEDs are green on both drivers - which I assume means they're good.

Any suggestions?

As an alternative, I have a PoStep 60-256. Is there enough juice to wire the pair of Nema 23's in parallel to it?

Phil

Offline philaro

  • Active Member
  • Posts: 8
    • View Profile
Re: PoKeys 57CNC, and P'25-32 and Mach 3 slave mode not working.
« Reply #1 on: June 04, 2018, 08:32:56 PM »
Just to make things interesting, for a while today A started working and X axis stopped.  But after juggling things around more it went back to plain old "slaved drive is not working."

Is there any issue with running 25-32 and 60-256 drives together?

Offline philaro

  • Active Member
  • Posts: 8
    • View Profile
The solution was - replace the DIY cables from the PoKeys kit with common and inexpensive 10 pin ribbon cables ("printer cables" -- 5 for $9.00 on Amazon). Whatever fault in whatever cable it was allowed motors to run but not for a slaved drive to work. Even after moving all the cables between different motors and board connections it was the same result. So I guess the lesson is that if you have a mysterious problem with your Pokeys 57CNC add DIY cables to your "suspect list".

I'd say that of all the DIY things to make cables are among the least rewarding, especially if you count potential reliability issues. And I'm one of those people who go out of my way to make as much of my machine from my own design and fabrications as possible.  8)