Hello Guest it is October 25, 2021, 09:37:55 AM

Author Topic: Latest update gives probem with Shuttle Express  (Read 1440 times)

0 Members and 1 Guest are viewing this topic.

Latest update gives probem with Shuttle Express
« on: May 29, 2018, 05:43:59 AM »
I went to use my router this morning and found Mach3 wouldn't start. This proved to be the Windows 10 update problem, so I installed the latest version of Mach3, and it now starts up OK.

However, I have a problem with the Shuttle Express on this version. The outer jog dial starts the axes moving OK, but they do not stop when the dial is centred. To stop them I have either to hit the reset button, or to operate the jog dial in the opposite direction.

There is a secondary difference in that there is no longer any audible feedback when I press one of the button on the Express that I use to select an axis. This is less important, though the audible feedback is nice.

I have tried with and without the Shuttle drivers installed, and it makes no difference.

Hoping someone will have an idea of what the problem is, and thanks in advance for any assistance,

Rgds, Andy
Re: Latest update gives probem with Shuttle Express
« Reply #1 on: May 29, 2018, 05:52:47 AM »
Hi,
this has been a topic of concern recently:
http://www.machsupport.com/forum/index.php/topic,37291.0.html

Craig
My wife left with my best friend...
     and I miss him!
Re: Latest update gives probem with Shuttle Express
« Reply #2 on: May 29, 2018, 06:15:03 AM »
Thanks Craig, that addresses the original problem of the unpatched Mach3 not starting up, but I can't see any reference to my subsequent problem with the Shuttle Express on the patched version.

I'm hoping this is just a difference of configuration between the old and new versions, rather than a problem with the program code.

Regrettably it isn't practical for me to have my computer permanently disconnected from the internet, and rolling back to the previous Windows version would only be a short term solution as you can't really stop Windows updating for ever.

Rgds, Andy
Re: Latest update gives probem with Shuttle Express
« Reply #3 on: May 29, 2018, 06:23:37 AM »
Hi,
This is a bit of a guess, but,Check and see if the jog mode is in Step rather than Cont. You can bring up the jog page by pressing the tab key.

Peter
----------------------------------------------------
Homann Designs
http://www.homanndesigns.com
email: peter at homanndesigns.com
Re: Latest update gives probem with Shuttle Express
« Reply #4 on: May 29, 2018, 07:16:31 AM »
Well Peter, I think you are a genius ;-) That fixed the problem - that's something I think I would never have found by myself :-)

I suppose you don't have any idea about the lack of audio feedback when the buttons are pressed? Not so important, but it would be nice to have that back again.

Thanks you ever so much for your help :-)

Rgds, Andy
Re: Latest update gives probem with Shuttle Express
« Reply #5 on: May 29, 2018, 07:21:17 AM »
Ooops, it has, however, had a side effect - if I use the keys on the keyboard for fine control, it now moves very fast instead of just one step at a time. My modus operandi used to be to use the shuttle to get close, then the keyboard for the last few steps. Is there a way round this, do you know?

Rgds, Andy
Re: Latest update gives probem with Shuttle Express
« Reply #6 on: May 29, 2018, 07:23:43 AM »
OK, I can use the middle dial on the Shuttle to single step, I will have to get used to using that instead of the keyboard :-)

Rgds, Andy
Re: Latest update gives probem with Shuttle Express
« Reply #7 on: May 29, 2018, 07:49:28 PM »
Unfortunately I’m no genius. I just persisted until I found the issue, as sometimes the shuttle worked correctly and other times not.

Cheers

Peter
----------------------------------------------------
Homann Designs
http://www.homanndesigns.com
email: peter at homanndesigns.com
Re: Latest update gives probem with Shuttle Express
« Reply #8 on: May 30, 2018, 03:44:03 AM »
Well, thank you again, I'm well pleased to have it working again