Hello Guest it is July 07, 2020, 01:45:28 PM

Author Topic: Limit switch not working  (Read 845 times)

0 Members and 1 Guest are viewing this topic.

Limit switch not working
« on: April 23, 2018, 05:28:48 AM »
I have absolutely no expirence with anything cnc related but have just picked up a used syil x4 cnc mill. It was functioning however simce since getting it home the y axis limit switch isnt registering. All other switchs are working.

-Ive replaced the switch and  have checked it with a multimeter and it is getting power - A lower reading compared to the others however.
-Ive noticed in the mach3 program there is a yellow flashing box thats labeled “abnormal condition” and when clicked it says “Plane  modified G17/G18/G19
-when looking in the control box of the machine Ive noticed a few wires that arnt plugged into anything One is a white wire that is bunched with the x asis limit switch wires.
Tthe other is the two wires runing from the “Estop” terminal of the breakoit board that  run into a male plug, it seems like its female half is labeled “ K1 K2” thats on another board (not sure if this is relevent or not)
-Another thing ive noticed is there are 4 “wire tape” type connections that run from the break out board to 4 black boxes, on the black boxes there are 3 indicator lights there status are
X- green and red are on
Y- red is on
Z- red is on
A- green and red is on

I cant seem to find a wiring diagram or any material that matches what i have. If anyone could help troubleshoot  the issue or point me in tye direction of information to - it would be greatly appreciated.
Re: Limit switch not working
« Reply #1 on: April 25, 2018, 01:26:40 AM »
Hi,
does this look like the correct manual?

https://www.peu.net/syil/X4_User_Manual.pdf

Craig
My wife left with my best friend...
     and I miss him!