Hello Guest it is December 09, 2019, 11:28:50 PM

Author Topic: Output for Limits and homing  (Read 611 times)

0 Members and 1 Guest are viewing this topic.

Output for Limits and homing
« on: April 22, 2018, 06:29:47 PM »
Hello,
I am running Mach4,C11GS and UC100. I'm trying to set up homing and soft limits and have watch a ton of videos but cant seam to get it to work. On the output side DEVICE and OUTPUT name I don't know the settings in this are. I have tried a few different settings but the switch wont work. The light is working on the C11GS board but not in mach 4.
A Leaphart
Re: Output for Limits and homing
« Reply #1 on: April 23, 2018, 10:12:19 AM »
Hello,

It sounds like your switches are working but Mach4 either isn't receiving the signal or doesn't know what the information means. Do you have home switches and physical limit switches? Both need to be assigned in Configure>Mach>Input Signals. For example, you would need to find Motor 0 Home in that tab, enabled it, select your UC100 as the Device, and select the port/pin it is wired to in the Input Name column. Test the configuration by manually pressing your switch and checking the Machine Diagnostics page to see if the corresponding LED lights up. If the LED is activating when the switch is not pressed and turning off when you press the switch, switch your Active Low setting back in the Configure>Mach>Input Signals tab.

Your soft limits are not switches but software boundaries that will also help protect your machines. Once you have your home switches set up, you can set up a soft min and max for each axis based on your machine coordinates. There is a wizard in Mach4 to assist with that and I also made a video going over some of the basics here: https://www.youtube.com/watch?v=IXuuGRACU1I

Happy CNCing,
Bryanna
Newfangled Solutions Helpdesk: http://support.machsupport.com
YouTube Support Channel: https://www.youtube.com/c/MachSupportOfficial
Re: Output for Limits and homing
« Reply #2 on: April 23, 2018, 10:41:04 PM »
Thanks a lot for you reply and time. I had the settings wrong. Its working now
Thanks A L:eaphart