Hello Guest it is September 24, 2020, 10:49:58 AM

Author Topic: G31 Probing with G68 Rotation enabled  (Read 1155 times)

0 Members and 1 Guest are viewing this topic.

Offline Zaae

*
  •  119 119
    • View Profile
G31 Probing with G68 Rotation enabled
« on: April 17, 2018, 11:34:53 AM »
Hello again everyone :)

I've noticed, if I use a G68A0B0R90 command, or if I enter a value into the "Local System Rotated" box on the MDI screen, when the probing starts (G31Z0, or auto tool zero on the main screen), the Z axis doesn't behave like it does without the G68 command enabled.

When the G68 is enabled, the Z does move down, but slower than normal, and both the X and Y axis sort of 'drift' away from the spot the probe command was initiated at.

Is there some way to change this behavior, so only Z moves during the probe?

Thanks!
Z

Offline Zaae

*
  •  119 119
    • View Profile
Re: G31 Probing with G68 Rotation enabled
« Reply #1 on: April 17, 2018, 01:40:24 PM »
Looking into this further, I tried the same process on my milling machine, running the same version of Mach3 as the other machine, it doesn't have this 'drift' oddity, which indicates to me it's definitely something in the settings or configuration. Now, figuring out which one it is ...

Offline TPS

*
  •  1,673 1,673
    • View Profile
Re: G31 Probing with G68 Rotation enabled
« Reply #2 on: April 17, 2018, 03:32:21 PM »
selected the right plane (G17)?
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline Zaae

*
  •  119 119
    • View Profile
Re: G31 Probing with G68 Rotation enabled
« Reply #3 on: April 17, 2018, 03:57:57 PM »
Yep, and I double checked the gcode as well, there are no G18 or G19 commands in there, only the G17 at the top.

I use the machine daily, this is something that's been on my list of things to tackle for a long time, it's just now becoming a problem, since I'm probing more often, and use G68 more often, too.

Thanks for the reply,
Z

Offline TPS

*
  •  1,673 1,673
    • View Profile
Re: G31 Probing with G68 Rotation enabled
« Reply #4 on: April 18, 2018, 01:48:47 AM »
post your both XML files, and i will do a compare für the Settings.
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline Zaae

*
  •  119 119
    • View Profile
Re: G31 Probing with G68 Rotation enabled
« Reply #5 on: April 18, 2018, 06:30:49 PM »
Hi TPS,

Thanks for offering to look at the xml files. So you know, these are from two very differently configured machines.

If you don't find anything obvious, I think I'll try setting up a fresh, blank configuration, with just the bare minimum to test, and see if that works.

Thanks,
Z

Offline TPS

*
  •  1,673 1,673
    • View Profile
Re: G31 Probing with G68 Rotation enabled
« Reply #6 on: April 19, 2018, 12:55:12 AM »
i am out today, will have a look tomorrow.
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline TPS

*
  •  1,673 1,673
    • View Profile
Re: G31 Probing with G68 Rotation enabled
« Reply #7 on: April 20, 2018, 03:17:56 AM »
made a compare of your profiles.

i can see three things witch may influence the probing, but i am not sure, but you can test.

here the three setting's i noticed:
- distance mode
- IJ mode
- soflimit's

Thomas

btw. here is a good mach3 Profile Viewer where you can also compare two profile's.

http://www.kd-dietz.com/klausphp/pages/eng/machprofile/description/m_profile_description.html
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline Zaae

*
  •  119 119
    • View Profile
Re: G31 Probing with G68 Rotation enabled
« Reply #8 on: April 20, 2018, 11:20:50 AM »
TPS,

Thanks a bunch for looking into that, and the link. I'll give those settings a try as soon as the machine isn't busy.

Thanks!
Z

Offline Zaae

*
  •  119 119
    • View Profile
Re: G31 Probing with G68 Rotation enabled
« Reply #9 on: April 21, 2018, 02:06:26 PM »
TPS,

Just a follow up here. I haven't done any "real world" probing today, just some tests, but it appears that the Distance Mode setting is the culprit here. I'm still not really sure why that setting would cause the G31 probing command to move X, Y and Z, instead of just Z, but I'm sure there's a reason, I just haven't found it yet. I'll dig into the manual again, and run some more tests today.

Anyway, thanks for helping solve the problem, I really do appreciate it!

Thanks,
Z