Hello Guest it is July 05, 2020, 04:20:50 PM

Author Topic: Win7 and the parallel port  (Read 3456 times)

0 Members and 1 Guest are viewing this topic.

Win7 and the parallel port
« on: April 16, 2018, 04:02:21 PM »
Hello all,

Recently, Windows rolled out several updates across their operating systems and those who had been using Win7 with a parallel port connection found that starting Mach3 would cause a system crash. If you can, it is always best to run Mach3 offline and without automatic updates. In reality, this is not always possible and hiccups like this are bound to happen. I have included a link below to an article below which explains how to uninstall updates in Windows 7 once they have occurred. The culprit of this particular issue is update KB4093118.

Windows 7: https://itstillworks.com/remove-windows-7-updates-8169897.html

I hope this helps save you some headaches!

-Bryanna
Newfangled Solutions Helpdesk: http://support.machsupport.com
YouTube Support Channel: https://www.youtube.com/c/MachSupportOfficial
Re: Win7 and the parallel port
« Reply #1 on: May 11, 2018, 07:18:20 AM »
I've had the same problem, but could not find KB4093118 installed on my system.
It appears this was an April 10 monthly security rollup update, which has now been superceded by the May 8 monthly security rollup. KB4103718.
Removing this update fixed my crash problem.

Malcolm
Re: Win7 and the parallel port
« Reply #2 on: May 11, 2018, 08:02:24 AM »
Thank you for sharing that, Malcolm. I installed the May updates on our Windows 7 testing pc overnight and will be doing some testing today. I suspected that update would be the culprit again this month and you have confirmed my suspicion.

-Bryanna
« Last Edit: May 11, 2018, 08:04:41 AM by bryannab »
Newfangled Solutions Helpdesk: http://support.machsupport.com
YouTube Support Channel: https://www.youtube.com/c/MachSupportOfficial
Re: Win7 and the parallel port
« Reply #3 on: September 05, 2018, 10:37:37 AM »
Update:

A recent Windows 7 security update has affected those who use Mach3 and Mach4 with a parallel port connection. Basically, when the parallel port is used to control your machine it "takes over" the operating system and the new update does not like it, so it crashes the whole system. The following is a fix that does not require you to uninstall any updates or upgrade to an external motion controller. These are still valid options, but this is quick, easy, and should have you back up and running in no time. Here are the instructions, which I'll break down for you below:

 

Go into command prompt with administrator rights and paste and add the below registers.

reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management" /v FeatureSettingsOverride /t REG_DWORD /d 3 /f

reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management" /v FeatureSettingsOverrideMask /t REG_DWORD /d 3 /f

Restart the computer for the changes to take effect.

(You do not have to change MinVmVersionForCpuBasedMitigations.)

https://support.microsoft.com/en-us/help/4073119/protect-against-speculative-execution-side-channel-vulnerabilities-in

 

You can follow along with these instructions at our support video here: https://youtu.be/C_O6TQhgMlA

1.) Go to your start menu and start typing 'cmd'. The command prompt (or cmd) option should appear right away. Right click and select 'Run as Administrator.' You need to be using an administrator account as well.

2.) Once you've opened the command prompt and see 'Administrator' along the top, you're almost there. Copy the first line that starts with 'reg add'. Right click in the command window and select 'Paste'. Then hit your 'enter' key.

3.) Repeat the previous step with the second line of code: copy and then paste into the command prompt window on the next line. Hit 'enter'.

4.) You should received a successful message after each line. If you see an error message regarding your access being denied, you should double check that you are logged in to an account with administrative privileges and that you are running the command prompt as an administrator (see step 1).

5.) Restart your computer.

6.) Open Mach3 and get to work.

7.) Happy CNCing!


Thank you to MachMotion for sharing this fix with us.
-Bryanna
« Last Edit: September 05, 2018, 10:40:41 AM by bryannab »
Newfangled Solutions Helpdesk: http://support.machsupport.com
YouTube Support Channel: https://www.youtube.com/c/MachSupportOfficial