Hello Guest it is October 15, 2019, 08:21:48 PM

Author Topic: Mach 3 Stepper Motor stall  (Read 703 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 Stepper Motor stall
« on: April 10, 2018, 07:33:46 AM »
Hi First post but been lurking on the forum for a while now.
Just a bit of back ground, I running my own CNC router cutting service business in Cape town. I have had my first machine (3000mm x 2000mm 3 axis Unincam CNC router, Vcarve CAM & Mach 3) for the last three and a half years, and had to learn how to run, trouble shoot and fix my self after the after sales service from the supplier proved disapointing.
Anyway just brought a new machine into the workshop and am having a couple of issues that I am hoping you guys will have some ideas on...
The new machine is a Chinese built machine but with the electronics replaced wit better quality (see attached). Its basically a 1200mm x 1200mm table, Ball and screw drives on XY&Z  with Nema 23 motors (no slaves). Electronics are PC motion control though LPT, Leewen BOB, and Gecko 203 drivers.
Problem is, I got the machine set up and calibrated as per the mach 3 manual, Machine happily jogging all ove the table at mav velocity of 4000mm/min but when I put in a sample Gcode from Vcarve with Mach 3 Arcs ATC (mm) post processor (100mm Circle, Square & triangle profile cut) the machine stalls out the stepper drives in the first pass on the square. Specificaly it starts the cut at the bottom left cornber of the square runs up the y axis then seem to stall at the turn on to the x axis. the machine is not actually cutting as I have set the z 20mm above the surface of the material.
I have attached a screen shot of the Mach three page at the point were the motor stalls...every time at the same line in the Gcode. Have also uploaded the Gcode text file and XML for the set up.

This machine was happily running at the previous owners shop and has an almost identical electronics set up as my first machine.

Offline TPS

*
  •  1,389 1,389
    • View Profile
Re: Mach 3 Stepper Motor stall
« Reply #1 on: April 10, 2018, 09:28:06 AM »
i think it is  a velocity and/or Acc/Dec Problem.

try some easy test by put

for example

g0x300
g0x100

into MDI line

just to see that your machine is able to follow the Speed/acc you configurated.
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Mach 3 Stepper Motor stall
« Reply #2 on: April 10, 2018, 09:49:40 AM »
Thanks, running the test I did notice there was a bit of juddering in the Y axis. Powered down the gantry moves freely and also under jogging. I have fiddled with the Velocity and Accel setting in the motor tuning page (and saved them) and didn't make a difference to the problem.
Running some more tests will let you know.
L
Re: Mach 3 Stepper Motor stall
« Reply #3 on: April 10, 2018, 10:29:10 AM »
Yeah! One problem solved. Re-installed Mach 3.043.066 and the stalling of the motors stopped... Cut the circle square and triangle G code and performed nicely, all dimensions spot on. However on the square there was a slight "judder" in the cut line on the top left and bottom right corners on the Y axis. Nothing on the circle, and a VERY slight judder on the corners of the triangle...
I am feeling like this is the momentum of the machine (it is heavily built)..... would that mean slowing down the acceleration...?
L

Offline TPS

*
  •  1,389 1,389
    • View Profile
Re: Mach 3 Stepper Motor stall
« Reply #4 on: April 10, 2018, 11:28:42 AM »
try to run v062

ftp://ftp.machsupport.com/Mach3/Mach3Version3.043.062.exe

and then "Play" a Little bit with Speed/acc settings
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.