Hello Guest it is May 20, 2019, 01:01:53 PM

Author Topic: Step loss on Mach3  (Read 3332 times)

0 Members and 1 Guest are viewing this topic.

Step loss on Mach3
« on: November 14, 2005, 07:52:54 AM »
Hello, I'm using the latest version of Mach3 and loosing one step everytime I change direction.
If I jog my machine with lowest resolution so I got only one step each time I press arrow button,
and press X+ and then X- then the axis moves only in one direction. But if I run the same thing
Mach2 then it works as it should. I have tried to play with step and pulse widht under motor tuning
maybe I could see a small improvement with a longer dir pulse but not enought.
What could be different between Mach2 and Mach3 with the step/direction function?

Best regards
Roger

Re: Step loss on Mach3
« Reply #1 on: November 14, 2005, 09:00:57 PM »
Roger,
What are you running for a drive? I think you are going to need to change the Pulse width to 5 and the Direction prechange to 5 on the motor tune page. If this isn't working please try the serline mode on the ports and pins page.

If that will not do it we are going to have to look deeper  ;)

Thank you
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Step loss on Mach3
« Reply #2 on: November 15, 2005, 06:45:41 PM »
I hooked up my scope meter and saw that I had delay on rising edge after the
opto couplers, I changed some resistors and know it works perfect. :)
Then I discover that when I was using Mach2 my hardware missed every first
step in both directions, thats way it ended up right anyway.
Thats was tricky to find. ???

Thank you
Roger
Re: Step loss on Mach3
« Reply #3 on: September 12, 2014, 03:27:35 AM »
Hi Roger
I have similar issue. I did not understand what you did to   make steps run correctly. Could you describe more for me? thanks a lot,
Valters