Hello Guest it is June 18, 2019, 03:42:26 AM

Author Topic: 4-axis lathe. How do I set up motor outputs?  (Read 1902 times)

0 Members and 1 Guest are viewing this topic.

4-axis lathe. How do I set up motor outputs?
« on: July 14, 2007, 10:33:49 AM »
I am developing a lathe with two cross slides. Each cross slide has two axes. Go to www.hicklerbanjo.com to see earlier prototypes. I have been reading Mach 3 turn documentation and discovered that, in theory, you can hove more than three axes. I found that you can configure motor outputs and was hoping that is the place to configure new or non-default axes. I went to config: ports and pins: motor outputs. I enabled X, Y, A and B. I was hoping to use X and Y for one cross slide and A and B for the other cross slide. I clicked OK to save my motor output configuration. When I returned to the main window I only saw the default X and Z axes listed. Restarting the program did not help. I reopened the configuration screen and my motor output selections were still there.

I should probably mention that at this point I am awaiting a 4-axis controller and motors I had ordered. I am trying to get some knowledge of the software before the hardware arrives. If anyone in the community has ideas for this unusual configuration, I would appreciate it!
Re: 4-axis lathe. How do I set up motor outputs?
« Reply #1 on: July 22, 2007, 02:10:40 PM »
Hello,
You need to change the screen to make the lathe screen show more then 2 axis... To do this you should have a look at the videos that are online about screen design.


Thanks
Brian

PS A lathe is setup with X and Z not X and Y... If you would like to use X and Y you will need to run it as a Mill and not a lathe
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com