Hello Guest it is May 23, 2019, 07:40:20 PM

Author Topic: Mach3 , jogging with limits switch on makes the axis move very slow one way  (Read 691 times)

0 Members and 1 Guest are viewing this topic.

So I have been muddling through the homing and limits. I got the homing working great. But when I activate the limit switch, the axis(x or y)
Will move at normal speed in one direction and real slow when I switch directions. I must have a settting messed up.
Any suggestions?

  Thanks. Rick

Offline Davek0974

*
  •  2,500 2,500
    • View Profile
    • DD Metal Products Ltd
It should move at slow speed until the limit switch is released IIRC but I'm unsure if it will speed up gain until you release the jog and do it again.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives
When I said that I activated the switches, I mean the button on the control that lights up green when it’s active. I wasn’t referring to the actual switches on the Axis’s. When I startup the machine and home the switches, the table does move slowly till it hits the switches , then it backs off the switches and calls that home. Then it will jog normally. But when I push the limit switch button on the control the machine will jog normally one direction, but trying to jog the opposite direction it moves very slow and makes a weird noise while moving, like it’s really laboring.Is that still normal?

« Last Edit: April 03, 2018, 06:15:45 AM by Tarzan »

Offline Davek0974

*
  •  2,500 2,500
    • View Profile
    • DD Metal Products Ltd
Don't push the limit switch :)

That was sarcasm, but seriously, why push a limit and try to jog?
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives
Ok, I must be confused about this.
On the Program page, under the DRO, there is a "soft limits" switch. That is the switch I am talking about. So I should not use that?

Offline Davek0974

*
  •  2,500 2,500
    • View Profile
    • DD Metal Products Ltd
Ah, soft limits, getting it now ;)

Yes you want that.

Before pressing it, you need to get the machine homed(referenced) and work out what your soft-limits actually are - mostly about 2-3mm before each hard limit(if fitted) or 2-3mm before the maximum travel of each axis.

Those figures are then entered into the "limits" table in the "soft min" and "soft max" columns, save the data and exit the page.

Now, jog to a safe position somewhere near mid axes on all axes if you are setting XYZ in one go and the press the soft-limits button.

Fingers crossed you will not get any error messages and the LED will stay on - your soft limits are now set and you can happily jog about without risk of hitting the ends.

The jog speed should also be as defined in Jogging % on whatever screen that is on.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives
Perfect. I will try that. Thank you for your help

Offline Davek0974

*
  •  2,500 2,500
    • View Profile
    • DD Metal Products Ltd
No worries.

It may be easier to set up and turn on one axis at a time, all that matters is that the machine is homed and "inside" the soft-limits zone when you press the button or you get an error.

In general use the 'soft-limits" button is on all the time, it should be persistent and stay on each time you start Mach up.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives
I use Soft limits to, have no switch on my 3040... it works very good, only probs is,, i set slowdown zone to 10mm, but it keep on at chosen speed to the softlimits stops it, it do not speed down...