Author Topic: Ethernet SmoothStepper Probe routine GetVar(2002) Problem  (Read 947 times)

0 Members and 1 Guest are viewing this topic.

Offline ballistic42

  • Active Member
  • Posts: 106
    • View Profile
Ethernet SmoothStepper Probe routine GetVar(2002) Problem
« on: March 22, 2018, 02:58:23 PM »
Have an issue with a probe routine.  I turn machine on, home it and then do a touch off routine of the part in the X, Y and then the Z.  When I do the corner probe routine the Z works fine.  When I use the Z button to probe just the Z sometimes it works and sometimes it just drives the probe into the part.  I am using the wildhorse digitizer probe, it  works well.  Something is getting confused with the Z probe routine and need help to see if maybe the smooth stepper is missing something.  Attached is the routines.

Thanks,

Jeff

Offline ballistic42

  • Active Member
  • Posts: 106
    • View Profile
Re: Ethernet SmoothStepper Probe routine GetVar(2002) Problem
« Reply #1 on: March 22, 2018, 02:59:12 PM »
Here is the Z probe routine as well, forgot to add it.

Jeff

Offline TPS

  • Active Member
  • Posts: 1,119
    • View Profile
Re: Ethernet SmoothStepper Probe routine GetVar(2002) Problem
« Reply #2 on: March 22, 2018, 03:39:33 PM »
ok there is one important difference in you probing routines:

1. the edge finde Routine

Call SetDRO (2,0.000)
Code "G4 P0.025" 'Pause for Dro to update.
Code "G90 G0 Z.500" 'retract Z to .500 inch

here you set your Z-axis to 0 and the go up to 0.5 (absolute)

2. the z probe

Call SetDRO (2, PlateThickness) 'set the Z axis DRO to whatever is set as plate thickness
Code "G4 P0.25" 'Pause for Dro to update.
Code "G0 Z1.0" 'retract Z to 1.0 Inch

here you set Z-axis to plate thickness (what ever in DRO 1002 is) and the go up to 1 (absolute)

so if DRO1002 >= 1in you will go into material

 
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline ballistic42

  • Active Member
  • Posts: 106
    • View Profile
Re: Ethernet SmoothStepper Probe routine GetVar(2002) Problem
« Reply #3 on: March 22, 2018, 03:50:15 PM »
I see that but I have "0" in the plate thickness.  I would think that from what I see the probe goes down touches the material, then should go up to the .5 above the part when doing the Z routine.  Am I not understanding what is going on?  I am confused then why it works sometimes and not other times.  Seems if I touch the X and Y first then Z touch gets messed up.

Offline ballistic42

  • Active Member
  • Posts: 106
    • View Profile
Re: Ethernet SmoothStepper Probe routine GetVar(2002) Problem
« Reply #4 on: March 22, 2018, 03:52:53 PM »
What if I just turn off that line in the code since I am not using a plate to touch off anyway, but I tried that as well and still did the same thing...

Offline TPS

  • Active Member
  • Posts: 1,119
    • View Profile
Re: Ethernet SmoothStepper Probe routine GetVar(2002) Problem
« Reply #5 on: March 22, 2018, 04:06:33 PM »
you can also try to replace this line:


Code "G0 Z1.0" 'retract Z to 1.0 Inch

with:

Code "G91 G0 Z1.0" 'retract Z to 1.0 Inch
Code "G90"

but i am not sure the retract goes into material, or the G31

best way would be to runn the code in VB scripter window,
and step through the code by using the >||, to see where
the fault happens.

btw have you watched the index Input in diagnostic Screen, when
the fault occurs ?
« Last Edit: March 22, 2018, 04:08:17 PM by TPS »
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.