Hello Guest it is December 11, 2019, 06:15:53 AM

Author Topic: Z Axis will only move in one direction Upwards (Z+)  (Read 673 times)

0 Members and 1 Guest are viewing this topic.

Z Axis will only move in one direction Upwards (Z+)
« on: March 18, 2018, 07:07:23 AM »
Switched the machine (Sieg KX1 Mill) on first time for a few weeks, but the Z Axis will now only travel upwards in a Z+ direction. The X and Y axes are working normally.
Press "Page Up" key the DRO moves positive and the Machine moves Positive as normal, but press GOTO Zero the DRO moves to Zero as normal, but the Machine moves Upwards by the distance on the DRO
Press "Page Down" key and the DRO moves negative as normal, but the Machine moves positive (Upwards). Press GOTO zero the DRO moves to zero as normal, but the Machine moves Upwards by the distance on the DRO
Can anyone tell me if this is likely to be a Software or a Hardware problem  

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Z Axis will only move in one direction Upwards (Z+)
« Reply #1 on: March 18, 2018, 07:42:03 AM »
You need to measure the voltage on the direction pin at the drive. It should be 0V in one direction, and 5V in the other direction.
If it's not, move down the chain until you find where the issue is.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Online Tweakie.CNC

*
  • *
  •  8,021 8,021
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Z Axis will only move in one direction Upwards (Z+)
« Reply #2 on: March 18, 2018, 07:49:35 AM »
Check in Config. / Ports and Pins / Motor Outputs that the Step Low Active is set the same for all three axes.
If you can physically swap the Z axis for either the X or Y then see if the problem follows the motor or the axis (a broken or bad connection stepper wire can cause this type of fault).

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Z Axis will only move in one direction Upwards (Z+)
« Reply #3 on: March 19, 2018, 07:38:47 AM »
Thanks for your help on this matter, it enabled me to know what I was looking for, and when I removed the Control Cubicle cover plate, the Z axis started to work again as normal and explanation, I believe, is the fitting of the cover plate to the Sieg KX1 control cubicle cover plate. This is on the RHS of the machine is held by six screws, one in each corner and two in the middle. The cubicle tapers in at the back by about ten degrees or so and the top edge is 25mm shorter than the bottom edge and the taper starts just above the middle screw at the back, and nearly in line with the parallel port entry socket. The screw hole in the cover plate is about 4mm out of line with its threaded hole in the cubicle, so that when replacing the cover, the pressed steel cubicle has to be sprung back by 4mm which means the Cable Socket is pulling on the breakout board printed circuit where it connects. The reason I believe this to have been the problem is that I have previously had problems with the Y axis not working, but when I removed the cover, it also started working normally, but I used put this down to an over heating issue, and used the machine with no cover on.