Hello Guest it is October 17, 2019, 04:50:25 AM

Author Topic: Plugin problems and licence for mach3  (Read 3642 times)

0 Members and 1 Guest are viewing this topic.

Plugin problems and licence for mach3
« on: March 13, 2018, 11:41:22 AM »
Hi
I have used fully licenced mach3 and Galil for a number of years, Great. With ethernet.
I now have some real problems and need some help.
Previously I have used 21xx ethernet controlers and now would like to use some 17xx and 18xx controlers. ISA and PCI.

         I have to use a diferent computer but I belive the licence for the galil plugin with mach3 is for me and not tied to one PC, am I mistaken with that??

        If I am wrong about the licence where do I get a new one, the only one I can find is for mach4 ??

        The program runs fine and the controllers show up as connected but as soon as I try to move an axis it freezes with error message "device driver could not be opened, or a read write error occured"
This is version 4.5 of the plugin.  Version 4.6 wont run at all and can not be configured in plugin setup. Causes mach to close down instantly.

        Both the 17xx and 18xx work fine with galil wsdk and smart term.

Thanks for any help
John
Mad rush on a treadmill gets nowere
Re: Plugin problems and licence for mach3
« Reply #1 on: September 10, 2018, 10:46:38 AM »
My understanding is that the Mach3 license can be used on as many machines as you wish. Just copy the file Mach1lic.dat into the Mach3 folder on your new machine. Mach4 licenses must be purchased for each machine. I have had problems configuring the Galil-ST plugin, I seem to be able to configure it on a new profile one time, but then cannot configure it again, Mach3 locks up.