Author Topic: Mach4 spindle control - no voltage through pin 17  (Read 865 times)

0 Members and 1 Guest are viewing this topic.

Offline rndpig

  • Active Member
  • Posts: 16
    • View Profile
Mach4 spindle control - no voltage through pin 17
« on: March 10, 2018, 06:11:20 PM »
I'm banging my head against the wall. I've followed the Pokeys57CNC/Mach4 guide and feel like I've got all the settings correct, but I'm not getting any voltage out of pin 17 to control the speed of the spindle through the VFD. In the Pokeys config > miscellaneous, the 'Enable PWM outputs' box is checked (freq set to 20000 Hz), the pin 17 enable box is checked with default (%) set at 0, and the Spindle output dropdown is set to Pin 17 (set to 0 when OFF is checked). Is there anything else I need to do to have Mach4 tell the Pokeys57CNC to send voltage through pin 17?

Ryan

Offline NeoTO

  • Active Member
  • Posts: 504
    • View Profile
    • PoLabs
Re: Mach4 spindle control - no voltage through pin 17
« Reply #1 on: March 11, 2018, 04:11:22 AM »
1. Configure Mach4 with correct spindle speed ranges (at least the first one)
2. Activate spindle
3. Set the spindle speed (note that override slider doesn't set the speed!). E.g. run MDI command S5000 in Mach4.
www.poscope.com home of PoKeys USB HID, IO, USB, Ethernet controler and PoScope USB PC oscilloscope

Offline rndpig

  • Active Member
  • Posts: 16
    • View Profile
Re: Mach4 spindle control - no voltage through pin 17
« Reply #2 on: March 11, 2018, 09:10:24 AM »
Thanks, NeoTO. That was the ONE thing I neglected to try, and entering 24,000 maxRPM for spindle 0 immediately fixed the problem. Are there any other settings on the Mach config spindle page that I should worry about? Accel or decel time? Max spindle motor RPM (default is 3600)?

Ryan