Hello Guest it is May 22, 2019, 01:14:36 AM

Author Topic: G4 Dwell time only reading whole numbers  (Read 493 times)

0 Members and 1 Guest are viewing this topic.

G4 Dwell time only reading whole numbers
« on: March 01, 2018, 02:54:46 PM »
Whether I have .1 seconds or .9 seconds as my dwelll my machine is pausing for the same amount of time. This is also true for when I have 1 second or 1.9 seconds for my dwell. It seems to be only reading whole numbers. Also, I tried switching to milliseconds in general config but even with milliseconds selected it is still reading the values for the dwell as seconds. Can anybody help me? Is there some setting I have to change somewhere?
Thank you,
Beau

Offline Tweakie.CNC

*
  • *
  •  7,764 7,764
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: G4 Dwell time only reading whole numbers
« Reply #1 on: March 02, 2018, 02:06:18 AM »
After you have selected G04 Dwell in mS close Mach3 then restart.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: G4 Dwell time only reading whole numbers
« Reply #2 on: March 13, 2019, 10:57:44 AM »
Tried it couldn't get it to take milliseconds. What we ended up doing is using and inverse feed rate value to tell it to move a certain increment over a certain time, then it was able to take decimals.
For example
G0 Z2
G1 Z2.001 F240

60/240 = .25 seconds, so it would take .25 seconds to move .001 (2-2.001)