Author Topic: MPG not working correctly with galil and mach 3, error code 9 and 46  (Read 1064 times)

0 Members and 1 Guest are viewing this topic.

Offline fbmstar

  • Active Member
  • Posts: 11
    • View Profile
Hello all,
   I am having issues trying to get my z axis to jog with a MPG.  The lathe has X, Y, Z axis with the X and Z being controlled by the MPG1, and MPG3, respectively.  MPG1 is tied to Galil X axis auxiliary input, MPG3 is tied to Galil Z axis auxiliary input.  This was working quite well with the galil plugin 4.4.0.0. 

I updated the plugin to 4.6.0.0 because it looks like this plugin has the option to use a 0-10v input signal for spindle control, which is something I'd like to utilize.

After updating, i noticed a couple of errors, error 9 and 46.  I think error 9 mentioned something about variables being off and error 46 mentions axis master/slave issues.  I don't have any axis tied together in the axis slave screen.

After playing around with some settings, i am able to get the x axis to jog with MPG1 and MPG2.  I can also make the Y axis jog with MPG2, but cannot get the z axis to jog with either of the MPG's.  I can get both X and Y to work at the same time as well.  I haven't tried any other settings. 

A couple of other things I noticed after updating the plugin:
1. the ports and pins section was filled out for MPG1 and MPG2.  (i think 1,13,1,15).  I was under the impression ports and pins don't need to be used with the galil plugin, but could be mistaken here.  If they do, i haven't been able to locate a pinout for what they should be.
2. The green check mark to enable the MPG's  in the ports and pins screen doesn't seem to work.  The MPG seems to work fine with or without the checkmark.
3. On the jog tab, there are two buttons, MPG axis and second axis.  I can't click on the second axis button at all.  Well, i can, but it doesn't appear to operate.  But i just realized that if i click on the MPG axis button, it will switch between the x and z axis, and low and behold the z axis will move with the MPG.

Is there anyway i can disable this link between the X and Z axis and get these to each work with their own MPG?

Any help would be much appreciated.  Please let me know if you'd like any additional information.

-Brian