Hello Guest it is August 05, 2020, 06:35:15 PM

Author Topic: mach3 randomly doesnt follow the correct toolpath  (Read 3722 times)

0 Members and 1 Guest are viewing this topic.

mach3 randomly doesnt follow the correct toolpath
« on: February 06, 2018, 07:12:57 PM »
Hi
i have a cnc machine with 5 axis , i usually use only 3 axis ,i have this machine for a month now ,but i cannot run it for long toolpaths ,even with short toolpaths it runs wrongly..
it has 5 stepper motor which are set to 4.5 Amp ,and the motors are 4.5 amp too ...the power supply in total has around 25 AMP of 36 volt...
the problem i have is when i run a toolpath ,even a short one ,sometimes (on short ones it happens 1 in 10 or 15 of the exact same gcode) means same gcode that has been running correctly ,it happens when i re run it sometimes... or with long toolpaths ,it definitely happens a few times...
i generate the gcode by fusion 360 and i let it to step down maybe 0.1mm or 0.2... then when it completely finishes the first or second or third row of gcodes ,when the z goes down for example from -0.3mm to 0.4mm ,the coordinate of x and y ,completely changes ,and the rest of gcode and toolpath runs in a different spot.... that ruins the workpiece completely... and also the tool breaks sometimes...
the computer where the visual toolpath is showing ,actually shows the toolpath coordinate has been moved... and starting the rest of it in a diffrent spot.... and also on the workpiece... i cant say its the gcode ,because sometimes same gcode works well and no problem ,next time same gcode gets the same problem ,and the problem can be in any level of z ...when z is changing and going down another level....
here i show u the pic of the vistual toolpath on mach3 ,and the workpiece ,which u can see how the toolpath is being followed in a different spot and the workpiece completely being ruined....
please help me , i am new in this and need you guys help ! i thank you for your help and sharing your knowledge
Re: mach3 randomly doesnt follow the correct toolpath
« Reply #1 on: February 06, 2018, 07:36:52 PM »
Hi John, welcome to the forum.
That sounds like a pretty impressive machine you have there.
Please post the XML file for the profile that you're using.
Will look for any anomaly there.
Welcome,
Russ
 :)
Re: mach3 randomly doesnt follow the correct toolpath
« Reply #2 on: February 07, 2018, 12:13:49 AM »
thank u for the reply ,i am going to send the xml ... i have modified the profile a few times tho... i brought down the velocity and acceleration of the x , y , z axis
« Last Edit: February 07, 2018, 12:16:50 AM by John_77 »
Re: mach3 randomly doesnt follow the correct toolpath
« Reply #3 on: February 07, 2018, 12:15:13 AM »
thank you Russ here is the xml of profile...
Re: mach3 randomly doesnt follow the correct toolpath
« Reply #4 on: February 07, 2018, 12:27:04 AM »
Hi John.
Unfortunately, that is a pirated copy of the software.
It will continue to give you grief.
You can contact Artsoft/NFS for a legitimate license.
Till then, there isn't much we can do.
Regards,
Russ
Re: mach3 randomly doesnt follow the correct toolpath
« Reply #5 on: February 07, 2018, 12:37:45 AM »
thank you ,it came with the cnc itself! i am going to buy the mach3 right now ! is it possible to buy the software online? and not wait for the cd?
Re: mach3 randomly doesnt follow the correct toolpath
« Reply #6 on: February 07, 2018, 12:39:22 AM »
I think they send it online, but not sure of the business hours.
Re: mach3 randomly doesnt follow the correct toolpath
« Reply #7 on: February 07, 2018, 12:43:13 AM »
http://www.machsupport.com/licensing/
>Licenses are emailed almost immediately after you complete your transaction in the checkout.  Please view our terms and conditions for more details.
Re: mach3 randomly doesnt follow the correct toolpath
« Reply #8 on: February 07, 2018, 12:43:51 AM »
i just paid for the license online ,and tomorrow i will reinstall the mach3 ,thank you!
maybe this was the problem?
i purchased this cnc machine from china ,but i have separately purchased every stepper motor driver and breakout board and power supply and etc... u cant trust nothing with them .... lol ! thanks anwyay! i will let u guys know if the problem got fixed
Re: mach3 randomly doesnt follow the correct toolpath
« Reply #9 on: February 07, 2018, 12:49:35 AM »
Yes, that seems to be one of the common symptoms of the pirated products. Many of them come from china.
You should notice quite an improvement with the legitimate license.
Keep us posted. Show off a cool project ... or 2  :)
I wish you all the best.
Cheers,
Russ
 :)