Hello Guest it is May 10, 2021, 09:49:54 PM

Author Topic: Mach 4 Stalling Out  (Read 1314 times)

0 Members and 1 Guest are viewing this topic.

Mach 4 Stalling Out
« on: February 02, 2018, 08:40:32 AM »
I'm having an issue with my mill and I'm not sure if it's due to Mach 4 or something else.  When I try to machine large gcode files (>20,000 lines) my mill will suddenly and randomly stop.  I don't get any errors in the history but all the axes are disabled and I have to restart Mach 4 in order to enable them again.  It's like the program fills up its memory and then says I quit.  It's done this a few times now and it's becoming a problem.

I'm running Mach 4 on a Windows XP machine with 8 gigs of RAM using an ethernet smooth stepper board.  Using Fusion 360 for CAM.  Any help would be greatly appreciated.
Re: Mach 4 Stalling Out
« Reply #1 on: February 02, 2018, 08:52:20 AM »
Are you running the DEMO ? or, do you have a license ?
The DEMO will time-out on ya, similar to what you're seeing.
Russ

Offline ger21

*
  • *
  •  6,293 6,293
    • View Profile
    • The CNC Woodworker
Re: Mach 4 Stalling Out
« Reply #2 on: February 02, 2018, 08:55:09 AM »
Unless you have a 64 bit version of XP, Mach4 can only use 2Gb of ram, and Windows itself only about 3Gb.
But I doubt that memory is your issue.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Mach 4 Stalling Out
« Reply #3 on: February 02, 2018, 03:11:19 PM »
I'm running a full Mach 4 Hobby license.  I'm not sure if the computer is 32 bit or 64 bit, I'll have to check when I get home.
Re: Mach 4 Stalling Out
« Reply #4 on: February 02, 2018, 04:40:31 PM »
Hi,
you don't say what motion controller you are using.

I use an ESS and you can if you run other software when Mach is running cause the ESS data buffer to run out. Usually though it posts an error code if that
happens. If memory serves though, there is a setting in the ESS plugin that enables/disables the buffer monitor. It may be your buffer is not being monitored and
could be stopping WITHOUT notification.

I run a dual core Atom based single board PC for my machine controller, a very VERY modest computing platform and worse uses on-chip graphics so falls well
below the NFS recommended minimum specs. I run 32 bit Windows7 so in effect have about 2.5 gig of RAM despite 4 gig being fitted and I run PCB routing
programs of up to 100,000 lines. I doubt therefore that your PC is running out of puff.

I rather suspect that noise is affecting your estop line. It might be difficult to prove given that it happens so infrequently. May I recommend fitting a small capacitor,
maybe 470-1000pF to your Estop input at your controller to earth. Certainly can't hurt.

By the way Fusion 360 is a 64bit only program, so if you are running Fusion on the same PC as your machine then your PC MUST be 64bit.

Craig
My wife left with my best friend...
     and I miss him!
Re: Mach 4 Stalling Out
« Reply #5 on: February 02, 2018, 05:16:52 PM »
Hi,
you don't say what motion controller you are using.

 

 




I'm running Mach 4 on a Windows XP machine with 8 gigs of RAM using an ethernet smooth stepper board.  
Re: Mach 4 Stalling Out
« Reply #6 on: February 02, 2018, 06:43:48 PM »
I am running an ESS with clearpath servos on a 64 bit machine.  I'll try adding a capacitor to the e-stop but I would think if the e-stop was triggered their would be a message in the history.  I'll also look into the ESS buffer monitor.

Any other suggestions?
Re: Mach 4 Stalling Out
« Reply #7 on: February 02, 2018, 08:23:27 PM »
Hi,
there is one instruction from Warp9 about the ESS and is repeated often is make sure that any wireless connection is disabled.

It would appear that it competes/interferes with the primary Ethernet connection.

Craig
My wife left with my best friend...
     and I miss him!