Hello Guest it is May 16, 2021, 05:49:22 AM

Author Topic: Spindle button disables stepper motors (Laser engraving on a 4 axis mill)  (Read 932 times)

0 Members and 1 Guest are viewing this topic.

Hello to everyone!
I've got a 4 axis milling machine connected to the 6600 board, spindle is manually turned on, not connected to the board (I use the milling machine mostly for engraving brass pieces).
I've recently bought a 2W chinese laser, one of those that come with a small router, to engrave metal tags an similar things.
I've taken the laser off the original controller and thanks to a friend I've connected it to the relay and a 12V power brick.
I've found a way to turn it on with the relay and to change the "power" of it with PWM, now when I set it at S0 it turns off and S100 is 100% on.
I've modified a post processor for Aspire so that I can vary turn on and off the laser with S commands while moving the all the axis, including the Z one.

PROBLEM: when M3 is issued the steppers stop working, DRO's move but the steppers seem to be lacking power.

If I manually turn the "spindle" off (hitting F5) the steppers start working again.

Any clue?

Thanks!

Offline Tweakie.CNC

*
  • *
  •  8,706 8,706
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Spindle button disables stepper motors (Laser engraving on a 4 axis mill)
« Reply #1 on: February 01, 2018, 01:50:15 AM »
Perhaps check your Ports & Pins allocation for a conflict.
or
If your stepper drivers require an enable signal that you have not used the allocated pin for your laser control.

Tweakie.
KEEP SAFE !
Re: Spindle button disables stepper motors (Laser engraving on a 4 axis mill)
« Reply #2 on: February 01, 2018, 01:45:56 PM »
Solved!
I had to activate (green tick) the Dir LowActive on the Spindle line in Motor Outputs.

On my TB6600 card I have this config:
Under Motor Output I have Spindle on Step Pin N. 16, Dir Pin N. 1, Dir LowActive on Green, Step Low Active on Red, Step Port on 1, Dir Port on 1.
Under Output Signals I have Output N.1 on Green, Port N. 1, Pin Number 14 Active Low on Red
Under Spindle Setup I have PWM Base Freq. at 500 and Min PWM at 0%.

This is with the Chinese 2W laser that sells for about 100 dollars on Ebay.