Author Topic: Mach4 Home switches  (Read 667 times)

0 Members and 1 Guest are viewing this topic.

Offline gene8522

  • Active Member
  • Posts: 117
    • View Profile
Mach4 Home switches
« on: January 13, 2018, 12:06:16 AM »
I have been running Mach3 for about 7 years W/ Screenset2010 on my DIY EVO CNC without many problems. Now for some unknown reason, while running a gcode file, about every two minutes I keep getting an error code (error 3336) pop-up that shuts the program down. ArtSoft technicians doesn't know what to do about it. So now I'm trying to install Mach4 V2 W/ Ess SmoothStepper to see if it will correct these problem. I'm having trouble setting the home switches. I have proximity switches on my X,Y & Z axis and the lights will change on the home screen so I know that they work. Somewhere along the way I'm missing some settings. When I try to 'Ref All' 'Z axis' will go up and trip the switch but nothing happens and Z will not back off of the switch. I have to push 'Stop' to keep from crashing 'Z'. Can anyone give me a lead where I might look to find a good description on setting up the home switches. You can't believe how fresh out of ideas I am. I've been at this trying to fix my EVO CNC for almost two weeks. The tech at ArtSoft gave me some things to try, like turn off my spindle VFD, new drivers for my video card. Wow this has been frustrating!!!!! ??? ???
Also how do I setup my keyboard to to run the steppers with the arrow keys?
Gene  

Online joeaverage

  • Active Member
  • Posts: 4,752
    • View Profile
Re: Mach4 Home switches
« Reply #1 on: January 13, 2018, 12:28:36 AM »
Hi,
firstly I would recommend having separate home and limit switches. It reduces confusion and Mach can then treat each switch in a dedicated manner.

When you flick the switches what shows up on the machine diagnostics page input LEDs? If you are using three motors the M0, M1 and M2 home LEDs should
light. If you are using the same switches as limits as well then the corresponding M0++, M1++ and M2++ LEDs should light ( or possibly M0--, M1-- etc).

On the Configure/Mach/Plugin page make sure that the keyboard plugin is enabled. If you have configured the ESS correctly you should see the on Machs input signals
page something like the attached. Note that you could directly set Machs input signals or as is recommended let the ESS do it when you set that up.

Craig
My wife left with my best friend...
     and I miss him!

Offline gene8522

  • Active Member
  • Posts: 117
    • View Profile
Re: Mach4 Home switches
« Reply #2 on: January 13, 2018, 08:45:14 AM »
Hi Craig,
I do not use limit switches. So I haven't been trying to set them up. Maybe i'm trying to set up my home switches in the wrong way. I have a closer look.
Gene

Offline garyhlucas

  • Active Member
  • Posts: 663
    • View Profile
Re: Mach4 Home switches
« Reply #3 on: January 13, 2018, 10:48:46 AM »
Gene,
Sounds like maybe active high/low may be backwards as I believe the home function likely uses edge triggering, where limits would not.