Hello Guest it is February 24, 2021, 10:06:07 PM

Author Topic: Mach3 Demo Not running as expected  (Read 1694 times)

0 Members and 1 Guest are viewing this topic.

Mach3 Demo Not running as expected
« on: December 06, 2017, 10:26:15 AM »
When I run an example gcode demo (i.e roadrunner), the gcode display cycles quickly thru the 1st four lines and hangs at line 5 (G43H5). For the next 20 seconds or so, there is no visible activity. After that, the next to last line of gcode (M5) highlights. It's as though the code may have been executing without the control panel updating.

In single Block mode, I am able to step thru the program, but all of the Axis  (X,Y,Z and 4) display remain as +0.0000.

I have installed Mach3 Demo Version R3.043.066 on two different Windows 7 machines and it behaves the same on both. One is 64 bit and the other is a 32 bitter.

It must be a cockpit error, but it's got me stumped. I have a Haas TM1 in my shop and run it regularly, so am very familiar with commercial CNC machines.

Where might I be going astray ?

Thanks

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Mach3 Demo Not running as expected
« Reply #1 on: December 06, 2017, 10:41:50 AM »
The demo is limited to 500 lines of g-code.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Mach3 Demo Not running as expected
« Reply #2 on: December 06, 2017, 04:05:16 PM »
Fair enough; I realize the demo is limited, but that is only part of the problem. I see now that "roadrunner.tap" in Mach3\G-code folder is much longer. I wouldn't have chosen it except that I watched a youtube example of roadrunner operating on a demo copy of Mach3.
It runs if I single step it, but the axis displays are stuck at the same values as those in the upper right corner of the offsets page. Obviously, I am missing something here.

Might you point me to a sample mill  G code file that will run properly on a freshly installed copy of the Mach3 Demo software;  using the default mill profile ? I understand machine coords, work coords etc.



Thank you
Re: Mach3 Demo Not running as expected
« Reply #3 on: December 06, 2017, 04:25:09 PM »
Hi,
if you don't have either the parallel port driver or external motion controller installed, ie unable to control motors
then the 500 line limit does not apply. If your installation is capable of running a machine then you need a licence
to get through the 500 line limit.

Mach4 Demo run for about 6 minutes before it needs to be reset and a licence is required beyond that. The exception
is if the Sim(ulator) plugin is used, ie unable to control a machine then the time limit does not apply.

Craig
My wife left with my best friend...
     and I miss him!

Offline Tweakie.CNC

*
  • *
  •  8,652 8,652
  • Super Kitty
    • View Profile
Re: Mach3 Demo Not running as expected
« Reply #4 on: December 07, 2017, 01:35:02 AM »
Quote
Might you point me to a sample mill  G code file that will run properly on a freshly installed copy of the Mach3 Demo software;  using the default mill profile ? I understand machine coords, work coords etc.

There are many here to choose from; http://www.machsupport.com/forum/index.php/topic,18345.0.html

KEEP SAFE !
Re: Mach3 Demo Not running as expected
« Reply #5 on: December 13, 2017, 09:41:06 AM »
Thanks to all for your tips. Things are looking up now.
Re: Mach3 Demo Not running as expected
« Reply #6 on: May 15, 2019, 07:03:33 AM »
You seem to have or had the same problem that I am currently having. My assumption was that the BOB was defective(same as yours) so I got another but the problem still existed. No e-stop or limit switch verification in MACH3 diagnostics by manual activation of the limit switch.