Hello Guest it is May 24, 2019, 09:46:16 AM

Author Topic: Mach3 Spindle output variation  (Read 696 times)

0 Members and 1 Guest are viewing this topic.

Mach3 Spindle output variation
« on: December 06, 2017, 09:07:15 AM »
Hey Forum,

I have some issues regarding the spindle output of my computer via paralell port connection.

Most of the times my machine works just fine, but from time to time i gat an error that i dont seem to be able to recreate on purpose and the problem usually stops after a various number of restarts.

Im using Mach3 on benezan triple Beast controller for my lasercutter.
The Spindle output (Pin 1 on parallel port) seems to drop in voltage to weird values. i already testet teh controller and its not gcode related, as the problem continues when i hit the controlls manualy. The Voltage (i use PWM signal to control the intensity of the laser ray) ot the declared pin jumps from 0 to 2 volts, alltough it should be 5 (at 100% intensity)

The values i have set in spindle setup are,
Declare the M§ and M5 command to output 1
x use Spindle motor
x PWM Control
PWM Base Freq. = 45
Minimum PWM = 10%
all the oteh boxes are unchecked

Did anyone ever have similar problems?

Offline Tweakie.CNC

*
  • *
  •  7,765 7,765
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach3 Spindle output variation
« Reply #1 on: December 07, 2017, 01:42:34 AM »
Pin 1 is often not used when it comes to parallel port operation (it is bit of an oddball).

Can you perhaps use a different pin (2 - 9, 14, 16, 17) ?

Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Mach3 Spindle output variation
« Reply #2 on: December 07, 2017, 02:57:39 AM »
Pin 1 is often not used when it comes to parallel port operation (it is bit of an oddball).

Can you perhaps use a different pin (2 - 9, 14, 16, 17) ?


Thanks, Tweakie
I have to check but i think i can find an unused pin!
I'll check that on monday, as im not in the shop for the rest of the week!