Hello Guest it is May 07, 2021, 08:22:27 PM

Author Topic: Teknic Clearpath Servo setting for Mach3  (Read 3263 times)

0 Members and 1 Guest are viewing this topic.

Teknic Clearpath Servo setting for Mach3
« on: December 05, 2017, 04:56:34 PM »
Hello,

I'm a bit confused regarding the "Steps per mm" setting. I replaced my Nema32 steppers with Clearpath Servo motors and tried to apply the calculation for steppers to the servo steps per mm but can not get the results that should be there with servos.

- Servos are tuned, no backlash

-> Stepper calculation was: 360 degree / 1.8 degree = 200 steps per revolution * 10 micro stepping = 2000 / 5mm leadscrew pitch = 400 steps per 1 mm

Values for the Clearpath servos:
Achievable Resolution 0.057 degrees
Repeatability 0.03 degrees

-> 360 degree / 0.057 degree = 6.315,7894736842 steps per revolution / 5mm leadscrew pitch = 1.263,1578947368 steps per 1 mm

So far my calculation ;)

Thankful for every pointer in the right direction!
Cheers,
J.

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: Teknic Clearpath Servo setting for Mach3
« Reply #1 on: December 05, 2017, 05:08:49 PM »
The steps per rev should be in the documentation..............

Just guessing it will be 12,000 per rev / 5 = 2,400
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Teknic Clearpath Servo setting for Mach3
« Reply #2 on: December 05, 2017, 05:14:24 PM »
Yes, it's provided:

6400 counts per revolution (0.05625° of rotation per count)

But it's not working...
Re: Teknic Clearpath Servo setting for Mach3
« Reply #3 on: December 05, 2017, 05:46:22 PM »
Hi,
when you say 'its not working' what do you mean? Does the servo turn at all? Need to get it to turn THEN
worry about steps/mm.

Craig

My wife left with my best friend...
     and I miss him!
Re: Teknic Clearpath Servo setting for Mach3
« Reply #4 on: December 05, 2017, 05:49:16 PM »
The servos are moving - no noises or stuff like that thanks to the Tuning software form Teknic.

It's not working because I'm approx. 0.02mm off the target move. (G0X1 entered and measured its 0.98).

The Vel. is set at 2000 and Acc. at 400.
Re: Teknic Clearpath Servo setting for Mach3
« Reply #5 on: December 05, 2017, 06:44:20 PM »
Hi,
have you tried Chaoticone's suggestion of 1200 steps per mm?.

When you perform a move to establish whether you have the correct setting try to move it as far as you can accurately measure.
Any measurement errors decrease, as a percentage, the bigger the move.

Also what following error window have you programmed into the drive?

My Allen Bradley servo I programmed the following error limit to be 20 count (8000 count per rev) and the zero window
as 4 counts. If your window/windows are too wide the drive may believe that the servo is in the correct location and not
bother to try and close the error any more.

Craig
My wife left with my best friend...
     and I miss him!
Re: Teknic Clearpath Servo setting for Mach3
« Reply #6 on: December 11, 2017, 08:05:03 PM »
After some trial & error the solution was adjusting the resolution within the Clearpath Servo settings plus eliminating a measurement error (ever so slightly angled probe).

Now the machine runs smooth!
Thanks again for the help - this forum rocks!
Re: Teknic Clearpath Servo setting for Mach3
« Reply #7 on: February 27, 2018, 12:14:28 PM »
Hi Hancock I too have the Teknic servos and instead of the servos being smooth they move in 15 degree intervals even though I have done both the tuning and the config in Mach 3 and the machine vibrates so badly it is unusable. Could you share what you did in the Teknic software to correct your issue please?
Re: Teknic Clearpath Servo setting for Mach3
« Reply #8 on: February 28, 2018, 07:00:29 PM »
Hi,
if hancock doesn't or cant reply can you post the manual, we may be able to help.

Craig
My wife left with my best friend...
     and I miss him!
Re: Teknic Clearpath Servo setting for Mach3
« Reply #9 on: February 28, 2018, 09:47:23 PM »
Thanks Joeaverage I reread the manual carefully and found that I had not ticked a box before exiting Teknics software and I had not tuned the servo correctly. As soon as I did that then they worked smooth as butter after that. They do say the servo can sound and run rough without proper tuning as it was not a smooth rotation but jerky every 15 degrees or so.
One also have to save the configuration Doh!

Thanks again this is a great forum as I'm just starting out with CNCing and it is the sharing of information that makes this hobby so interesting.