Hello Guest it is June 25, 2019, 02:50:26 AM

Author Topic: Setting tool height  (Read 749 times)

0 Members and 1 Guest are viewing this topic.

Setting tool height
« on: December 04, 2017, 07:41:45 AM »
Hi,
I've been using Mach3 for a number of years with very little problem. I have now encountered a problem with setting tool heights.
I have a quick change tool holder and have 9 tools available.
My method of setting my tool heights (which may sound odd to some, but has worked for all the time I have been using Mach) is as follows:-
First, I position the table to somewhere easily accessible for setting tool heights from the table and zero the X and Y position on the DROs.
I then open the tool table and zero all tool heights and enter tool diameters and tool type (for my reference) that I am about to reset, clicking apply and closing the table.
I have one tool (in this case No2 tool, that I very rarely ever change) and using a roller gauge (one that I made) with tool "0" selected, jog to touch the gauge on the TOOL HOLDER and set this at zero.
I then jog up to touch the tool tip I want to set (in this case, tool No 2), change the tool number to the appropriate tool - in this case, No 2 - in the Tool Information, noting that the Z DRO now reads the tool length and then click the "Set Tool Offset" button to set the height. This resets the "Z" DRO to zero. So far, so good.
I then jog the Z axis up for say 20mm or so and then click "Go To Zeros" button and the Z axis moves down to the zero point, which I then check with the roller gauge. If it is out, then I adjust the tool height by jogging in increments (say 0.0254mm) up or down to re-position the tip, set the Z DRO to zero, change the jog mode to continuous and repeat the jog up and Go to Zeros and recheck. If OK, I then click the "Set Tool Offset" button to reset the tool height/length.
I would then continue to all the other tools - using their respective tool numbers.
This, in the past, reset the tool offset to the new length, but now, for some reason, the tool offset reading does not change to the new length, in relation to the Zero set in tool 0.
I have even tried opening the tool table again and removing the offset/tool length (resetting it to 0.0000) and then trying the set tool offset again to no avail.
What has happened?
I did press the "Remember" button on the tool "0", which I haven't in the past. Will this actin have changed things?

To finish, when I come to carry out the machining operations, I set the tool X & Y positions to my start (zero) point and reset the X & Y to zero clicking the set Zero buttons for each. The "Z" height is then set with tool "0" selected with the roller gauge against the No 2 tool holder, press the Z DRO set to zero, then change the DRO to read the roller Gauge thickness. This sets the work height for all tool+offsets.

Where am I going wrong - I don't want to change to a new tool setting regime as I'm comfortable with my usual method, but can anyone tell me what has changed?

Regards,

GeoffB
GeoffB