Hello Guest it is June 18, 2019, 09:31:04 AM

Author Topic: Mach3 changed my Z settings by itself!  (Read 1014 times)

0 Members and 1 Guest are viewing this topic.

Mach3 changed my Z settings by itself!
« on: November 23, 2017, 06:08:41 PM »
i was happily running a gCode to make a part. I had my soft limits set and thought I had no worries. The gcode contains a drilling operation, followed by a profile operation. The drill operation went perfectly, then the profile operation kicked in and did one profile cut perfectly. Then it moved over to the next cut, and sank deep into my salvage board, past where the soft limit was set. 
Confused, I raised the spindle up, and to my shock, the settings on the z axis had been lowered almost an inch! I knew this because the stop limit had been lowered an ich from the top, which lowered the bottom stop limit and allowed the bit to sink deeply into the wood without the stop limit kicking in.
 What can the problem be? Everything has been running smoothly until this happened.
 It has happened twice so far. So it is not just a one time accident.

Offline Tweakie.CNC

*
  • *
  •  7,812 7,812
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach3 changed my Z settings by itself!
« Reply #1 on: November 24, 2017, 01:43:29 AM »
When the cutter sank deeply into the salvage board what did the Z Axis DRO read ?
Did the Z axis DRO show the correct Gcode dimension ?

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Mach3 changed my Z settings by itself!
« Reply #2 on: November 24, 2017, 05:01:05 AM »
tweakie,
 Unfortunately, I didn't notice the if it was the correct reading or not because I hurriedly pushed the stop button and raised the spindle to see if there was any damage to the spindle or bit.
 Luckily, i caught it in time and there was not.
 The odd part of this is that I am cutting ten 2" squares from plywood.Both times that this has happened, the 1st square will cut out perfectly, but when the spindle goes down to start cutting the second square, it goes deeper than is in the code.
And when I raised the spindle, the stop limit had been lowered an inch.
 I am going to run this code again today and see what happens.
 If it happens again, I am definitely going to check and see if the code matches up.

Offline ger21

*
  • *
  •  6,261 6,261
    • View Profile
    • The CNC Woodworker
Re: Mach3 changed my Z settings by itself!
« Reply #3 on: November 24, 2017, 06:20:00 AM »
This is most likely due to your stepper stalling and losing position.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Mach3 changed my Z settings by itself!
« Reply #4 on: November 24, 2017, 07:26:30 AM »
 tweakie,
 It may be.
 So, would it be better to increase or decrease the steps?
 

Offline Tweakie.CNC

*
  • *
  •  7,812 7,812
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach3 changed my Z settings by itself!
« Reply #5 on: November 24, 2017, 07:40:15 AM »
Your steps per unit should remain the same (assuming your machined dimensions are correct) but reducing the axis Velocity and Acceleration of your Z axis by 50% (and saving the changes) may help. But if it is lost steps (as Gerry suggested) reducing the Z axis feed-rate may also help.

If you can repeat the problem then the DRO readings from the Z axis will tell if it is lost steps.

Tweakie.

EDIT: Just read your post in the Mach4 section and if you think the problems you are having are bugs within Mach3 then please think again and perhaps read the Mach3 manual.
« Last Edit: November 24, 2017, 07:45:35 AM by Tweakie.CNC »
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Mach3 changed my Z settings by itself!
« Reply #6 on: November 24, 2017, 07:57:21 AM »
ger,
 Thank you. I have been talking to tweakie and didn't read the moderator's name in the reply. Sorry about that.
 And tweakie, yes i am thinking about upgrading to Mach4. It seems a good deal for $200. The hobby edition, I mean. But I just wanted to make sure the trial version was the same as the paid version, so that I would get no surprises if i purchase it.
 I turned everything on and my soft limits were moved!
 I am beginning to think there is a ghost in the machine.or more likely, a bug in my computer.
 I may have to uninstall Mach3 completely, perhaps even restore my computer, then either reinstall Mach3 or try Mach4.
 Which option would you suggest? Mach3 or 4?
 

Offline Tweakie.CNC

*
  • *
  •  7,812 7,812
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach3 changed my Z settings by itself!
« Reply #7 on: November 24, 2017, 08:10:01 AM »
If you are just starting out then I would recommend Mach4 (it is the future). You can download and install / run the full version of Mach4 Hobby free of charge - it is run-time limited but it will give you a good idea of it's capabilities. If you are satisfied then purchase the license to unlock the time limit and away you go  :)

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Mach3 changed my Z settings by itself!
« Reply #8 on: November 24, 2017, 09:38:47 AM »
  I may have came to the solution for this.
  The workroom I have is chilly. I believe that because of the cold, the Z axis is losing steps.
 I ran the gcode again and again, and at the beginning, it would sometimes slightly stutter.
 I am  turning up the heat the room and turning down the velocity and acceleration.
 Being new to this, I don't know if the cold affects a CNC machine or not. But it didn't do this when it was warmer.
 Does anyone know about cold affecting a CNC machine adversely?