Author Topic: Mach4 lathe threading with UC100  (Read 742 times)

0 Members and 1 Guest are viewing this topic.

Offline NORTONXSU

  • Holding
  • Posts: 1
    • View Profile
Mach4 lathe threading with UC100
« on: November 19, 2017, 02:12:43 PM »
Hi all, after many years running my Mirac lathe on Mach 3 I have upgraded to Mach4.
My old setup on Mach3 with UC100 allowed me to thread successfully  with a single pulse per rev index signal.
However on my Mach4 setup when I try to thread Mach4 freezes on the 2nd G76 line.
All other functions work fine, Mach4 is seeing spindle index pulse, rpm indication is spot on and feed per rev works OK.
Any suggestions?

Offline joeaverage

  • Active Member
  • Posts: 4,712
    • View Profile
Re: Mach4 lathe threading with UC100
« Reply #1 on: November 19, 2017, 02:43:47 PM »
Hi,
lathe threading is largely enacted by the motion controller. Not all motion controllers are capable at the moment.
The UC100 is a newcomer to Mach4, its Mach4 plugin is only a few months since release. I think a question of
CNCDrive is in order.

Craig
My wife left with my best friend...
     and I miss him!

Offline DazTheGas

  • Active Member
  • Posts: 743
  • DazTheGas
    • View Profile
Re: Mach4 lathe threading with UC100
« Reply #2 on: November 19, 2017, 03:01:59 PM »
Heres a post from march of this year, I could not tell you if there plugin or controller has been updated since

http://www.machsupport.com/forum/index.php/topic,34338.msg237514.html#msg237514

DazTheGas
Theres always time for a choccy biccy