Hello Guest it is May 24, 2019, 02:03:18 PM

Author Topic: Stepper motors slow  (Read 680 times)

0 Members and 1 Guest are viewing this topic.

Stepper motors slow
« on: October 31, 2017, 06:55:34 AM »
Hi there,   I build my own CNC plasma using Bobcam cad v64 and Mach 3 on my lap top with windows 10 and USB port  , driving 3 nema 34 steppers. Everything is working fine exept my cutting speed is slow but jog speed is fast. I had issues with my metric conversion that seems to be working now. I changed inches to millimeters in my post proccessor but did not insert my G21 in the beginning of my program could that be the problem. Please help as it is my first try at the CNC game.  Thanx guys

Offline Tweakie.CNC

*
  • *
  •  7,765 7,765
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Stepper motors slow
« Reply #1 on: October 31, 2017, 07:42:02 AM »
As far as Mach3 is concerned G20 and G21 are modal commands so it is good practice to always include the appropriate command at the start of every Gcode file. This is usually one of the jobs of the Post Processor.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Stepper motors slow
« Reply #2 on: October 31, 2017, 12:58:40 PM »
Thanx Tweakie will remove my mods and install G21 in all my files.... Luan
Re: Stepper motors slow
« Reply #3 on: October 31, 2017, 01:45:34 PM »
Hi,
on the Config/General Config page there is an area 'Initialisation String'. It is a small group of Gcodes that Mach runs when it starts. If you wish your machine to
be in inch mode as default when you start up code G20 in that string.

Your CAM program and Post Processor should put a G20 or G21 at the start of your code automatically.  Is there any documentation about your CAM program?
and have you read it?

Craig
My wife left with my best friend...
     and I miss him!