Hello Guest it is May 23, 2019, 07:36:59 PM

Author Topic: Cannot use tw0 gcodes that both use axis line 30  (Read 988 times)

0 Members and 1 Guest are viewing this topic.

Cannot use tw0 gcodes that both use axis line 30
« on: October 30, 2017, 10:46:38 AM »
I have made a part in Solidcam. I then put it in gcode form. when I start it in Mach3 it will load fine. But when I try to run it, I get the error message "Cannot use two gcodes that both use axis line 30.
 How is this fixed?

Offline Tweakie.CNC

*
  • *
  •  7,764 7,764
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Cannot use tw0 gcodes that both use axis line 30
« Reply #1 on: October 30, 2017, 11:51:06 AM »
Can you zip and attach the problem Gcode.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Cannot use tw0 gcodes that both use axis line 30
« Reply #2 on: October 30, 2017, 12:00:57 PM »
Here you go Tweakie.  I've attached the file. Thanks for replying and I hope you can see the problem.  I don't know if there is a setting in Mach3 that will make the program read this or not.

Offline Tweakie.CNC

*
  • *
  •  7,764 7,764
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Cannot use tw0 gcodes that both use axis line 30
« Reply #3 on: October 30, 2017, 12:34:22 PM »
Hi Pudly123,

Your Gcode is not correct (as far as Mach3 is concerned).
 
Basically the G28 has it’s own feed-rate and you cannot have a G00 on the same line.

Delete the G00 from lines N154 and N156 and insert a new line N153 G00

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Cannot use tw0 gcodes that both use axis line 30
« Reply #4 on: October 30, 2017, 05:04:32 PM »
Hello
 Thanks Tweakie.
 I changed it and it is running on the machine now.
 However, it is running in MM when it was made in inches.
 

Offline Tweakie.CNC

*
  • *
  •  7,764 7,764
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Cannot use tw0 gcodes that both use axis line 30
« Reply #5 on: October 31, 2017, 02:43:41 AM »
Hi Pudly123,

In the line N1 add  G20 (and save the change).

The Gcode will then run in inch units.

It should be noted that the G20 / G21 commands (which switch between Imperial and Metric units) are modal - they will stay in effect until such time as they are changed.

Tweakie.
« Last Edit: October 31, 2017, 02:46:49 AM by Tweakie.CNC »
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Cannot use tw0 gcodes that both use axis line 30
« Reply #6 on: October 31, 2017, 05:42:32 AM »
Tweakie, you have been immensely helpful.
 But I feel pretty dumb now, even as a noob.
I went back to check my motor setting and x and z were set way too low! That's why everything was cutting in what seemed like millimeters instead of inches.
I changed everything to the correct settings and the files are all in the correct inch dimensions now, even without the G20 code.
 So hopefully this will help some other newbie that finds themselves facing the same problem as me.
 Once again, thank you for your time and help.

Offline Tweakie.CNC

*
  • *
  •  7,764 7,764
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Cannot use tw0 gcodes that both use axis line 30
« Reply #7 on: October 31, 2017, 07:36:27 AM »
I am pleased that you have found and solved the problem and I am sure you have learned a lot about Mach3 & Gcode in the process. That's really what CNC is all about - learning  ;D

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.