Hello Guest it is May 22, 2019, 05:52:18 PM

Author Topic: Motor Output Pins won`t change  (Read 973 times)

0 Members and 1 Guest are viewing this topic.

Motor Output Pins won`t change
« on: October 26, 2017, 01:35:36 PM »
Hey Guys,

i downloaded the Mach3 Demo Version, and made the first configuration. It all works fine, i can move all axis with the arrow keys.
But i got a little problem. I got 1 Motor on X, 1 motor on Z, and 2 motors on Y.  I moved to config - slave axis and made the A axis slave to Y.
Now, if i change the Pins for the step and dir signal for every axis (like 2,3 to Z and 6,7 to X) nothing happens.
When i change it, the Z axis should move instead of the X right? Can anybody help me?

thanks guys,

andreas
Re: Motor Output Pins won`t change
« Reply #1 on: October 27, 2017, 05:18:36 PM »
Hi,
can't think of anything that would prevent you from doing what you've proposed.

When you alter any setting on the Config/Ports and Pins/Motor Outputs page the <Apply> button should become active. Is it? and are you using it?,
<Apply> sends the new data to your <profile>.xml file. I think you'll be required to restart Mach if you wish for the new data to be read, the xml file
is used by Mach on start up.

Craig
My wife left with my best friend...
     and I miss him!
Re: Motor Output Pins won`t change
« Reply #2 on: October 27, 2017, 05:25:25 PM »
hey,
i use the apply button, but nothing happens. after a restart of mach3 the pins are still changed, but the signals go out on the standard settings.

Andreas
Re: Motor Output Pins won`t change
« Reply #3 on: October 27, 2017, 05:56:49 PM »
Hi,
I think there is some confusion going on. When Mach starts up it reads a profile and will send signals to the outputs in that profile. If Mach is
sending signals out on your original setting its doing so because that is the profile its read. I think you are inadvertently saving new settings to one
profile but Mach is reading another.

Is this a new installation? If so may I recommend going to the Mach3 folder and deleting ALL your .xml files and starting again. Multiple profiles
is likely to end up in confusion particularly if your new to Mach.

Craig
My wife left with my best friend...
     and I miss him!
Re: Motor Output Pins won`t change
« Reply #4 on: November 02, 2017, 05:06:58 AM »
hey,
i deleted all. xml files und restarted mach3. after changing the pins nothing happend. after i restarted again nothing happend too. but after restarting the pc the pins changed. its all a little bit confusing :-)
Re: Motor Output Pins won`t change
« Reply #5 on: November 02, 2017, 05:12:19 AM »
Hi,
sometimes you need to re-start Mach to cause it to re-read a profile and sometimes you need to re-start you PC for  Machs Parallel Port Driver
to read new values and act on them.

Craig
My wife left with my best friend...
     and I miss him!