Hello Guest it is May 24, 2019, 11:42:18 PM

Author Topic: Calibration CONSTANTLY Changing  (Read 1089 times)

0 Members and 1 Guest are viewing this topic.

Calibration CONSTANTLY Changing
« on: September 29, 2017, 05:45:36 PM »
Here's our plasma steel cutting setup...

Autodesk Autocad 2018 (Design, save as DXF file) -> Airsoft Lazycam (Load DXF, add leading, get gcode) -> Mach3 (Auto calibrate motors, set home, zero and table size, load gcode, start cut)

Here's our problem...

Units are quite literally hit or miss. I'll set a rectangular cut that's 12" long and 6" deep and it will cut perfectly. Then, I'll load a washer with a 4" diameter and it'll cut it at 2.5". I'll re-calibrate everything and load the same code for the washer, and then it'll cut a 6" oval. I'll re-calibrate again, test with the rectangle and it'll cut 6" x 2.5"...

If someone could tell us what we're missing/doing wrong/not looking at, we'd greatly appreciate it as we're about to sell the whole setup!

If you're curious -->>  HP laptop well equipped, geko g540, shielded wiring, only utilizing x and y cuts (nothing fancy), rail system with rollers (no belts).

Re: Calibration CONSTANTLY Changing
« Reply #1 on: September 29, 2017, 05:57:59 PM »
Hi,
can you try cutting a few different shapes, without re-calibration in between, but without the plasma running?

I just wonder if electrical noise could be causing what you describe.

Craig
My wife left with my best friend...
     and I miss him!
Re: Calibration CONSTANTLY Changing
« Reply #2 on: September 29, 2017, 06:21:55 PM »
Hi,
second question...how is the motor rotation converted to linear motion? I noted that you said that your machine
Quote
rail system with rollers (no belts).
Does that mean that one or more of the rollers is hooked to the axis motor and the roller engages the rail and moves the axis backwards
and forwards? If that is the case then I would be investigating slippage between the roller and rail, it must be pretty dramatic to give you
the variations you've described.

Craig
My wife left with my best friend...
     and I miss him!
Re: Calibration CONSTANTLY Changing
« Reply #3 on: September 29, 2017, 06:29:21 PM »
You don't say what the code looks like. I don't see how any calibration, tuning, or slippage problem could turn a 4" circle into a 2-1/2" one and it is still round. Look at the code to see what it is telling the CNC to do. I'm betting it is an issue in making the G-code from the dxf.
Re: Calibration CONSTANTLY Changing
« Reply #4 on: September 29, 2017, 06:30:49 PM »
Hi,
last thing....at the moment anyway...is 'don't keep changing the calibration'. You said you calibrated the machine and then cut a 6x12 rectangle
and it came out right, then the calibration must be correct. If subsequently you cut a shape and its comes out at the wrong size it could be that
Mach and the PC have forgotten what the hell its supposed to be doing...extremely unlikely or something else is happening. By changing the
calibration you've added another variable, I understand your desire to have a shape come out the right size but continually changing the machine
settings is masking the real problem.

Try cutting the same shape several times, they should all be the same right? If there not you have something to investigate.

Craig
My wife left with my best friend...
     and I miss him!

Offline Tweakie.CNC

*
  • *
  •  7,765 7,765
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Calibration CONSTANTLY Changing
« Reply #5 on: September 30, 2017, 02:33:32 AM »
Which external motion controller are you using ?
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline RICH

*
  • *
  •  7,332 7,332
    • View Profile
Re: Calibration CONSTANTLY Changing
« Reply #6 on: September 30, 2017, 05:21:50 AM »
I assume your using the axis calibration  feature to  set the steps per unit. When using it and have the units steps correct you should Save Settings, exit Mach3 and restart Mach3. There should be no need to recalibrate the axes. Dry run /  jog to confirm Mach is configured properly.

--------------------------------

You should save the drawing  as a version 12 DXF and would recommend that that only levels to be used by LazyCam  (LC) are on when you save the dxf. For information on using LC read the manual and note that lead in's can be a  bit tricky. I assume you are have a license for LC and your using the Plasma Module. The following are basic steps for using the Plasma Module:
1.   Create a dxf and open in  LC .
2.   Select the Plasma Module
3.   Click Setup and on the bottom right you will see Plasma Options.
4.   Click the Plasma Options button so you can define your plasma settings. Click OK button
                  when done.
5.   Select what you want to cut.
6.   Click the Post Code button

Review the posted code and you will see that M3 & M5 are used to turn the plasma on and off.
The M3 macro needs to be correct for how you are using your machine. 

----------------------------------

Laptops can be used. BUT.........You make no mention of using an external motion controller.

RICH