Hello Guest it is January 25, 2020, 02:59:07 PM

Author Topic: Jog keys disabled during tool change?  (Read 953 times)

0 Members and 1 Guest are viewing this topic.

Offline Zaae

*
  •  115 115
    • View Profile
Jog keys disabled during tool change?
« on: September 25, 2017, 01:00:27 PM »
Hello all,

I've done a lot of searching about this, it seems it should be simple, but nothing has worked so far.

I can jog around just fine when I start Mach3. I load a program, run it, get to the first tool change, and the jog keys no longer do anything. I need to be able to jog to manually zero the next cutter. The "Jog ON/OFF" button is green, the keybinds are all still fine. The only way I can get the keys to work is is to press "GOTO ZERO", which is not what I want to happen. I have another machine, running the same version that doesn't behave like this. I've compared the general config settings between the two machine, and I don't see any difference. I'm sure I'm just missing a setting somewhere.

This just recently started happening, I don't know what changed. The last things I was working on was setting up a charge pump, and enable pin for my motor drivers. That all works fine.

I've attached my XML file, if it helps. Any ideas?

Thanks,
Z
Re: Jog keys disabled during tool change?
« Reply #1 on: September 26, 2017, 01:51:31 AM »
Hi,
this is just a guess, but when a Gcode program is active then jogging is disabled. It sounds like your Gcode job is still running even
tho its not doing much and that's why you cant jog. While in M6 can you <feedhold>, do the business and then <cycle start>.

Craig
My wife left with my best friend...
     and I miss him!