Hello Guest it is May 23, 2019, 03:23:51 AM

Author Topic: computer updated and now no stepper movement  (Read 880 times)

0 Members and 1 Guest are viewing this topic.

computer updated and now no stepper movement
« on: September 14, 2017, 01:00:50 PM »
hello

I used my cnc machine (g0704) Monday night. Wednesday morning at 3am my designated computer that runs mach3 updated and had an issue rebooting. I fixed the reboot issue and now my c10 breakout board is getting power through the printer port cable dimly energizing the breakout board, when the actual power to it is off. When I turn the power on for the BOB, my driver lights and BOB lights turns real bright(normal operation).  mach3 settings are the same...dro's move when commanded but no motor movement and the relay for my air solenoid is stuck on also... maybe printer port went bad???? please help if possible. thanks in advance

Jason
« Last Edit: September 14, 2017, 01:18:34 PM by 1K2J »
Re: computer updated and now no stepper movement
« Reply #1 on: September 14, 2017, 02:30:36 PM »
Hi,
do you use a parallel port? If you do run DriverTest.exe and post a screen shot if you can.

Craig
My wife left with my best friend...
     and I miss him!
Re: computer updated and now no stepper movement
« Reply #2 on: September 14, 2017, 04:23:25 PM »
yes I have a printer port. having an issue uploading pic.
Re: computer updated and now no stepper movement
« Reply #3 on: September 14, 2017, 04:25:26 PM »
here it is
Re: computer updated and now no stepper movement
« Reply #4 on: September 14, 2017, 04:52:33 PM »
Hi,
well that looks fine. Do you have an Estop button on your control box. Does it work? If it does then Mach and the control box are talking to each other
which is good news.

Does your BoB require a charge pump signal? If you take the cover of the box can you see/get to/probe the Dir pins of the BoB or drivers?
Thinking that if you have a multimeter you could probe the Dr pins while jogging backwards and forwards.

Craig
My wife left with my best friend...
     and I miss him!
Re: computer updated and now no stepper movement
« Reply #5 on: September 14, 2017, 05:21:27 PM »
I shut off the BOB a couple times and now it works normal again. Im going to pull the internet cable on this machine since its only for cnc. no need for this hiccup again. thanks for your time and help