Hello Guest it is May 15, 2021, 08:20:15 PM

Author Topic: Tool carousel does not move on referencing but....  (Read 855 times)

0 Members and 1 Guest are viewing this topic.

Tool carousel does not move on referencing but....
« on: August 12, 2017, 01:33:04 PM »
When trying to home my tool carousel, the Mach 4 dro's show the process, but the carousel itself does not move!

I can jog and move the carousel by mdi input! The home sensor shows up on my Hicon controller as well as in the Hicon diagnostics page!

I have 6 sensors used in the tool changer on this machine......carousel in position....home.....tool index, (reads each tool position as the carousel
rotates, tool in position, drawbar up and drawbar down! None of these sensors lite up in the Diagnostics screen when they are active! They
show up on the Hicon controller and on the Hicon diagnostics page.

My other axis's home sensors and overtravel limit switches all show up on the Mach diagnostics screen when they are active!

I am at a loss!

Mike

Offline mark4

*
  •  167 167
    • View Profile
Re: Tool carousel does not move on referencing but....
« Reply #1 on: August 12, 2017, 11:55:52 PM »
hi you can see the switches in the hicon that means electrically they are working and a plus. now you need to get mach to see them. if they are not lighting up on the diag screen in mach where are they mapped to in mach (you also need to map inputs/outputs in mach) i dont know if the controller you are using transfers settings to mach. also the diagnostics screen gives you leds but not for all inputs and outputs you can add leds to the screens to see what a particular output is doing i use them to show what my jogging switches are actually doing and am going to add on my new screen build two for the mpg a and b because i dont know what mach sees. good luck
mark
Re: Tool carousel does not move on referencing but....
« Reply #2 on: August 13, 2017, 01:42:48 AM »
also the diagnostics screen gives you leds but not for all inputs and outputs you can add leds to the screens to see what a particular output is doing
mark

Mark I think you hit the nail on the head! I did notice the other day that all the inputs were not displayed and wondered then if that was the problem all the while hunting for the leds that would show the sensors active!

Never made a screen change in my life and now looks like I am going to have to learn to do it!

Mike

Offline mark4

*
  •  167 167
    • View Profile
Re: Tool carousel does not move on referencing but....
« Reply #3 on: August 14, 2017, 12:55:52 AM »
one thing i can say about screen leds once you get them programed it is comforting to be able to see the input working or not working leaves the guessing out
mark