Hello Guest it is August 20, 2019, 10:44:35 AM

Author Topic: lost steps on y after a z move.  (Read 2787 times)

0 Members and 1 Guest are viewing this topic.

lost steps on y after a z move.
« on: August 09, 2017, 10:29:10 PM »
I have a strange problem that is repeated over many different g codes.

If I am machining a profile after each z down move I loose about 0.03 mm in one direction only. It seems to be reasonably consistent and on the vertical face there is a series of small steps in one side of the cut. So when i machine 2 mm deep with 0.2 mm steps the part is about
0. 3 mm  off center in one direction only. Always the same direction. always the y axis. The g code does not show the error on the tool path screen.  I have checked all the mechanical s. every thing is silky smooth, ball slides and screw with a second pre loaded ball nut for zero backlash. Not a machine geometry condition.
the machine has been working beautifully for at least 4 years now, it is stepper driven with a geko 540  and nema 23's.  Any suggestions of where to look will be greatly appreciated.
Re: lost steps on y after a z move.
« Reply #1 on: August 10, 2017, 07:09:44 AM »
swap geckos from one axis to another and see if the problem follows.  if so it's the gecko.  also check for loose wires on BOB
Re: lost steps on y after a z move.
« Reply #2 on: August 13, 2017, 06:53:45 PM »
 Thanks, I ran through all my connections(no loose screws found) and also set the pulse width in the motor setting page to 15 us. They were on zero. Made three good parts after that. Not sure which was the cure. Will post again if I find something conclusive.
Re: lost steps on y after a z move.
« Reply #3 on: August 18, 2017, 12:25:38 AM »
The problem has returned again. I used Cambam for  one job and Meshcam for the next and I have the same problem with the machine when using Meshcam. The tool path looks perfect but when  machining and the spindle goes to the retract position to machine the next section then I get a Y shift. Next is  to swap the axis in X and Y.  Any comments are appreciated.
Re: lost steps on y after a z move.
« Reply #4 on: August 18, 2017, 01:08:50 AM »
I have just swooped the X and Y axis and the problem has transferred  from y to x so it is on the computer side or geode side.  I will try the g code on my Dads mill with the same G code and see what happens.
Re: lost steps on y after a z move.
« Reply #5 on: August 18, 2017, 02:01:36 AM »
I have tried the same g code in another machine and it works fine. So it seems that the fault is transferred between axis  on the first machine, so not the steppers and not the Geko 540. Not the g code. I think i will reload Mach 3 next or try another computer.  Any more suggestions?

Offline RICH

*
  • *
  •  7,351 7,351
    • View Profile
Re: lost steps on y after a z move.
« Reply #6 on: August 18, 2017, 07:55:54 AM »
Buchanan,

It's good that your problem is repeatable as you can try things to find the culprit.

By swapping the axes and getting the same small additive error  it tells me that it is not the drive, gcode, or Mach.  ie; Mach controls the machine based on the gcode instructions created by the software which in turn goes to the drive.

The intial axis error is 0.03 mm ( which is 0.0012" ).
You say not a mechanical / geometry problem,but, not sure that is true.

So here are some suggestions:
1. Create a gcode file that simply duplicates the snippet of code for the sequence that seems to be problematic. You can then run that small code numerous times to re-confirm the problem while taking physical measurements and can also add in dwells to see what the dro says while doing it.

BUT, before you do 1.

2. What's the Y axis resolution?

3. Check / test to know what  the backlash of the axis is. Don't say zero, very unlikely, it may be small but it is there. Also the backlash may vary depending on the screw ie; can be different at different screw sections and when when going in different directions. Also, depending on acceleration it can change due to loading on the screw which also influences the trust bearing preload / movement.
Each part of the axis contributes to the system inaccuracy. Know what they are.

Let me add that getting axis accurate repeatable down to ( 0.03 mm / which is 0.0012" )  is somewhat easy but below that value really need to be meticulous and have good system compponents.

There is more that you can do, but, first know what you have.

FWIW,
Stay focused working on the problem  in a logial way of testing, one step at time and not doing all kinds of things.

RICH
« Last Edit: August 18, 2017, 07:59:34 AM by RICH »
Re: lost steps on y after a z move.
« Reply #7 on: August 18, 2017, 09:26:56 PM »
Thanks for your reply Rich.

I have checked the mechanics, I have ball screws with two nuts. One is fixed and the other is pre loaded against it.  This in the same on X Y and Z. Definitely not machine geometry as the difference in depth of cut is only 2 mm on any of the troublesome jobs.

Next I am going to swap X and Y on my pins and ports and see if the error swaps axis again.  That will prove it into the gecko drive area. I have checked the g code on another machine and it is good. I had a discussion with my sons yesterday afternoon and we came to your conclusion that the next is to write a custom G code . I will keep you posted. Thanks.

Re: lost steps on y after a z move.
« Reply #8 on: August 21, 2017, 02:38:35 AM »
Hello Rich.

These are my latest facts.

 I tried to find a G code to recreate the problem in a predictable way.

 I generated a G code on Cambam for a pocket 12 mm deep  in 0.4 mm Z increments and a return to clearance height between each level.

 This gave me a beautiful pocket, but found if I machined the same pocket in the same place I had a small Y shift so I generated another G code in Cambam :  a series of  10 identical diameter pockets but each one 1 mm shallower all machined in the same place.

  This produced a pocket with a series of 1 mm  steps in the y+ side of the pocket. Each about 0.01 mm  or a total of 0.1 mm increase in the diameter of the pocket from bottom to top in the y plane but not in the x plane.

 I swapped my  X and Y stepper motors around and the problem occurred on the X axis instead of the Y axis.   OK,  so it is not the Steppers or Mechanical.

Next I swapped X and Y axis on Ports and Pins. The problem remains on the X axis. 

I then corrected the X and Y steppers on their plugs and the problem returned to the Y axis even though the ports and pins were reversed.

 I tried the same G code in my old Dads little hobby mill and it worked perfectly.

 My conclusion is that there is a problem between the serial port plug and the stepper plug on the driver I  am using for thew Y axis.

Now I am using a Geko 540 so I cant change individual drivers but I have a 4th axis spare so I will now run the same test with the ports and pins set to bypass that one axis in the  Geko 540.

 I will also carefully check all my connections from the Y axis to the  Geko 540.

 I find it hard to understand why this only occurs on a new pocket, or,  when engraving a 3D shape the problem only occurs when a level or section is complete.
Re: lost steps on y after a z move.
« Reply #9 on: August 21, 2017, 02:40:51 AM »
One other comment is, the tool path always looks correct on Cambam,Meshcam or the Mach 3 screen.