Hello Guest it is October 20, 2019, 12:24:43 AM

Author Topic: Mach 4 And Hicon Motion Control With Automation Technologies KL-8070 Driver  (Read 2540 times)

0 Members and 1 Guest are viewing this topic.

Recently purchased the Hicon control board and got it installed. I set up 1 e-stop on my main panel that seems to function fine. After doing the Mach 4 config. And the Hicon config. I can't get any motion out of my motors. when i hit the execute button I can see that it is trying to move by looking at the commanded position but the motor will not rotate? The drive has the green power light lit up on it and as far as I can tell it is enabled. The board automatically disarms after it has reached the max error. I. Know motors and everything is wired right because I have had these motors running off of an ethernet smoother board. Any help on this would be much appreciated!

are you using the 7737 breakout board with Integra?

can you open the diag->hicon status window and see if the StepGen is counting when the command position is moving.

regards
Rufi
Sorry, the step generator is not counting.
Have you downloaded example mach4 profile from the integra web page. Looks like you're missing the basic configuration.
Just downloaded the file but can't read it when I open it up with notepad?
Run Mach 4 from the C:/mach4industrial folder. It will then ask you to select a profile. also there will be an option to import a profile. Click on import profile and browse to the location where you downloaded the Integra profile. Once  the profile is imported you will see it in the available profiles list. Select the new profile to launch Mach 4 and you should be good to go.
Started up with new profile and had the same result. When I run the test I can see command pos. Counting and error counts and it disarms when it reaches set error value.
can you make sure the Step/Dir is disabled for both J7 and J8?  You will need to vsiDeviceManager software to check that.

see attached picture.

J8 was enabled. I disabled it and motor tested out good. Thank you so much!!! I will sleep better tonight.