Hello Guest it is February 28, 2021, 05:27:03 PM

Author Topic: home x homes all axis'  (Read 1150 times)

0 Members and 1 Guest are viewing this topic.

home x homes all axis'
« on: July 07, 2017, 12:45:01 PM »
Hi,

I had my machine working just fine.

I created a button that said "home x" and it would home x

Now when I press the same button, it homes all axis' as if I hit "ref home"

Any ideas?

Thanks
Ben
Re: home x homes all axis'
« Reply #1 on: July 07, 2017, 01:57:31 PM »
I will also add that I am able to use "G28.1 X1."

But I just can't figure out why all of the sudden "home x" or DoButton(24) continues to home the z axis, then the y axis, then the x axis.

I am using a Warp 9 ESS and a PMDX 126.

I did add some outputs, which function perfectly.  I did disable a relay on the PMDX as it was using up an output pin...

I am stumped,
Ben

Offline ger21

*
  • *
  •  6,289 6,289
    • View Profile
    • The CNC Woodworker
Re: home x homes all axis'
« Reply #2 on: July 07, 2017, 06:07:06 PM »
Is the homing script in the button, or in a macro called by the button?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: home x homes all axis'
« Reply #3 on: July 07, 2017, 08:55:45 PM »
I created a button in a screen designer, I simply selected the radio button for home x, so no macro was created
Re: home x homes all axis'
« Reply #4 on: July 10, 2017, 03:43:07 PM »
I discovered my problem...

In the screen designer, the old "ref all home" phantom button still existed in the 'background'. Once it was fully deleted the problem went away.