Hello Guest it is October 17, 2019, 03:03:35 PM

Author Topic: Z-Axis moving only up and Jogs in same direction (up) for Joging Up or Down  (Read 1235 times)

0 Members and 1 Guest are viewing this topic.

Older CNC Wood Router Z-Axis stepper motor moves up Jogging Up or Down
If I swap the Y and Z-Axis does the same thing, only Jogs in one direction, but now the Z-Axis Jogs correctly

I think this maybe a Mech3 software issue. Not a motor or wiring issue. Replaced stepper motor driver board and interface boards.

The Z-Axis on the CNC router moves in the same direction when jogging Up or Down using Mech3 software. Don't know how to correct the problem and if it is PMDX boards, gecko drivers, Mech3 software. I know it is not the motors and motor connection as I switched the Y-Axis and Z-Axis Green connectors on the PMDX-133 board and it operated the same on the Y-Axis.

Back ground:  overheated and pins on the PMDX and Terminal Blocks were burnt. Replace the PMDX-133 with a new board and replace the green phoenix contacts #1934900 with new ones. At first it worked then the Z-Axis stopped working. it only goes up for jogging Up or Down.

We also tried swapping out the Gecko G203V with a G201X board that we had on hand. still the same, so probably not the Gecko motor controller.
Anyone have a know what might be wrong? Maybe a Mech3 software issue, but not familiar with the software other than running it. Thank you in advanced Craig, Dallas, TX

Offline Tweakie.CNC

*
  • *
  •  7,951 7,951
  • Super Kitty
    • View Profile
    • Tweakie.CNC
How does it behave from the MDI screen ?

Try:  G0 Z5

Does it go up ?

and:  G0 Z-5

Does it go down ?

Tweake.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.