Hello Guest it is January 28, 2020, 08:34:57 AM

Author Topic: Mach 4 Mill Spindle Issues  (Read 887 times)

0 Members and 1 Guest are viewing this topic.

Mach 4 Mill Spindle Issues
« on: June 12, 2017, 05:52:06 AM »
Hi All,

I am new to this forum in the quest for some help on an issue i have run into on my converted cnc mill, i converted a mill and lathe about a year ago, running Mach 4 and a ESS smoothstepper board with a C6 and C41 breakout board for spindle control.
I use one electronics enclosure to run either my mill or lathe, i have had it running well for sometime now and all of a sudden 2 days ago i started experincing issues with my spindle control on the mill.

When i load a file and hit cycle start it starts up and the spindle kicks in then shuts down and everything stops, if i discconect the spindle motor from the vfd it all runs fine after restarting mach 4. If i open my lathe profile while connected to the mill and do a M3 command it runs with the spindle connected no problem. I have been through the settings countless times but everything appears as it was before.

I haven't the foggiest where to start - if anyone can point me in the right direction i would be most greatful. I have had problems in the past and have just nutted it out and searched forums for the answer but this time i have come unstuck, I figure it's time to get involved in these forums and hopefully someone else will benefit from it with the same issue oneday.

Kind regards,
Ash
Re: Mach 4 Mill Spindle Issues
« Reply #1 on: June 13, 2017, 08:29:56 PM »
Wow what an overwhelming response, looks like i'll have to go it alone - when I do sort it out i'll put my solution in here so that someone else in my shoes might find it helpful.

Offline smurph

*
  • *
  •  1,187 1,187
  • "That there... that's an RV."
    • View Profile
Re: Mach 4 Mill Spindle Issues
« Reply #2 on: June 13, 2017, 08:32:53 PM »
Well...  I think it is going to be very particular to how you machine is setup.  And we all can't look at that.  :( 
Re: Mach 4 Mill Spindle Issues
« Reply #3 on: June 13, 2017, 08:57:47 PM »
@Smurph At least you responded, Thanks.
Re: Mach 4 Mill Spindle Issues
« Reply #4 on: June 14, 2017, 07:35:17 AM »
I didn't get to the bottom of why or how this issue suddenly appeared but i have solved it for now by going to a backup prior to it doing what it did, i have run a few files and all seems to be ok. Wish i had thought of this earlier would have saved myself alot of trouble.