Hello Guest it is July 06, 2020, 11:28:17 PM

Author Topic: Mach3 w/smoothstepper and EStop issue...  (Read 1229 times)

0 Members and 1 Guest are viewing this topic.

Mach3 w/smoothstepper and EStop issue...
« on: June 05, 2017, 06:51:20 AM »
I'm trying to finalize my SmoothStepper install with Mach3 and an "existing" profile. The eStop was working fine but now the physical eStop is works but the software eStop in Mach is not working.

Does anyone have any suggestions on how to fix this?

I'm seeing the following in the History log when starting Mach and hitting the Estop:

Quote
Mon - 06:49:09 ---Program Startup
Mon - 06:49:10 ---ReConfiguration Estop.
Mon - 06:49:13 ---Application Watchdog Triggered
Mon - 06:49:32 ---Limit Switch Triggered
Mon - 06:49:35 ---command killed due to buffer error.

Adam,


Re: Mach3 w/smoothstepper and EStop issue...
« Reply #1 on: June 05, 2017, 08:42:01 PM »
We'll come to find out I don't have an issue, well besides me. I was remembering incorrectly
how Mach handled an eStop on my machine.

Sorry for the noise.

Adam,
Re: Mach3 w/smoothstepper and EStop issue...
« Reply #2 on: April 17, 2018, 03:19:06 PM »
Any luck on the 'Application Watchdog Triggered' error? I'm getting the same message and I'm having random e-stops that need the controller power cycled to reset.
Re: Mach3 w/smoothstepper and EStop issue...
« Reply #3 on: April 18, 2018, 09:27:41 AM »
Oscar, go into the SS plug in and set the watchdog timer to 3.1
Re: Mach3 w/smoothstepper and EStop issue...
« Reply #4 on: April 18, 2018, 09:33:54 PM »
I've adjusted the watchdog timer and still get the same issue. I can't find any reference anywhere to "Application Watchdog" and what it might mean. A lot pf people report Driver watchdogs but not Application.